Problem with MXAO in Parkitect [It's upside down]

  • Posts: 3
4 months 3 weeks ago - 4 months 3 weeks ago #1 by kabbage222
I can't find any way to fix this. And i've seen the RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN threads but those are for the old versions.
That option doesn't exist in the new one now. How do i fix this?
Also when trying to edit the options under Processor, it changes back to zero or that default 2.

Please Log in or Create an account to join the conversation.

  • Posts: 19
4 months 3 weeks ago #2 by Vreem
The definitions are also for current version. I did test that: if I use RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=1 then MXAO shows similar as your screenshot.
Check in your ReShade.ini under [General] if this line is present:

PreprocessorDefinitions=RESHADE_DEPTH_LINEARIZATION_FAR_PLANE=1000.0,RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0,RESHADE_DEPTH_INPUT_IS_REVERSED=1,RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0

If not, add it and see if it works.
I have the same line also in my own ini file but I don't know if that is necessary. Don't remember if that was generated or that I put it in myself :p

Please Log in or Create an account to join the conversation.

  • Posts: 7
4 months 3 weeks ago - 4 months 3 weeks ago #3 by Cul

kabbage222 wrote: Also when trying to edit the options under Processor, it changes back to zero or that default 2.

If you right click > Properties the folder with the .exe & Reshade, then Security tab, does your user have a tick ✔ next to Write?

I remember some people had to change that, otherwise Windows doesn't let Reshade write anything new into a folder in Program Files, for example.

Please Log in or Create an account to join the conversation.

  • Posts: 3
4 months 3 weeks ago #4 by kabbage222
Yes it worked now, i edited it in the Reshade.ini file next to the games exe from 0 to 1 and it worked. Didnt know it was there i just thought its in the ingame menu somewhere.
Thank you guys!
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.