GPU anti-aliasing settings don't work with Direct3D9 games

More
3 weeks 4 hours ago - 3 weeks 4 hours ago #1 by elishacloud
Hello crosire, I have been working on integrating some of the ReShade features into the Silent Hill 2 code-base. However, whenever ReShade is enabled the anti-aliasing features of the GPU stop working. I narrowed it down to the following line of code here .

If I remark out this line of code then everything seem to work. I am not sure if removing this code will cause any issues or if there is a better way to fix this. Any comments or suggestions would be helpful. Thanks!
Last edit: 3 weeks 4 hours ago by elishacloud.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #2 by crosire
That effectively disables depth buffer detection. The only way I can think of that affecting AA is that it replaces the main depth buffer with a surface using the INTZ format, which I believe does not support multi-sampling. There is a checkbox in the ReShade UI on the DX9 tab which says "Disable replacement with INTZ format" and disables that though. So you could try uncommenting the line again and instead hit that checkbox. If AA works again, that is the culprit.

Please Log in or Create an account to join the conversation.