Welcome, Guest.
Username: Password: Remember me

TOPIC: quint_lightroom's lut not working well

quint_lightroom's lut not working well 2 months 1 week ago #1

So i used lightroom to color grade the game to my liking took a screenshot , cropped it perfectly using the TileSize*NoOfTiles as width and TileSize as the height, saved it as a .png with no compression put it into the reshade-shaders/textures folder as lut.png and finally used lut.fx to load it but the end result is not even remotely close to what lightroom was giving me at first i thought the problem was the that lut.fx was expecting a 1024*32 size lut and i was giving it a larger one but even by changing the proportions of lut correctly in lightroom and repeating the process i still did not get the correct result. Also it's worth mentioning that i had no other shaders loaded when i was using lightroom so theres no chance that some other shader could have messed up the lut. Would appreciate some help as this game desperately needs some color grading.

Edit: found a fix, to set lut luma amount to 0 which just so happens to be exactly the same fix i had to use back when i made my first lut back then i just assumed it was something i did wrong but now i think it might be a problem with lut.fx instead.
Edit: Edit: Yup i think i found a bug in lightroom for some reason despite setting both tile size and no of tiles to 32 the first tile in the lut seems to have a width of 33 pixels instead of 32 all the others seem to have 32 width though (i think, haven't checked)
Last Edit: 2 months 1 week ago by availableusername.
The administrator has disabled public write access.

quint_lightroom's lut not working well 2 months 1 week ago #2

The administrator has disabled public write access.
The following user(s) said Thank You: availableusername

quint_lightroom's lut not working well 2 months 1 week ago #3

IT worked!! Finally!! Thanks a lot mate!
The administrator has disabled public write access.

quint_lightroom's lut not working well 2 months 1 week ago #4

No problem. Had to battle this issue some time ago as well. :)
The administrator has disabled public write access.
The following user(s) said Thank You: availableusername