Welcome, Guest.
Username: Password: Remember me

TOPIC: Question on Assetto Corsa's in-game depth buffer

Question on Assetto Corsa's in-game depth buffer 5 months 14 hours ago #1

Hey guys, I've recently finally been able to make ReShade work with AC, but sadly:
1-When in the race cars aren't rendered in the depth buffer AT ALL, and I mean it. There are trees, some level decorations and stuff, but still no car models showing up there, and it's really crucial for DoF effect. Personally I really like the in-game DoF, but I find McFly's Advanced DoF far more superior, so it's such a shame I can't use it properly - even Mouse-driven autofocus won't help much there.
At first I thought "This is it, big thanks to devs then!" :(
But then I stumbled upon a picture on AC forums where one guy showed off his depth buffer output pic, and the car model actually WAS there! I couldn't make cars appear though, that's why I decided to ask if anything can be done there here, on forums.
2-Another problem (though I wouldn't call it that important) is that ReShade won't even show up loading when I enter the Showroom even knowing that I placed all the files where they belong, and yet again ReShade works/ loads fine in-game, but not in Showroom.

Thanks in advance!
Regards, polyneutron
Last Edit: 5 months 14 hours ago by polyneutron.
The administrator has disabled public write access.

Question on Assetto Corsa's in-game depth buffer 5 months 14 hours ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
1) Not really. You cannot affect the search algorithm ReShade uses. Maybe the guy was using an older version.
2) I guess the showroom isn't rendered via Direct3D or OpenGL, which is required for ReShade to work.
Cheers, crosire =)
Last Edit: 5 months 14 hours ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: polyneutron

[Solved] Question on AC's in-game depth buffer 5 months 13 hours ago #3

Funny thing is that I tested prev version of ReShade (*the one I successfully use in pCARS), and it didn't work, it just CTD'ed the game. Now I tried to leave both "Reshade 2.0" and pCARS' Reshade folders at the same time, hooked on the 0.18.3 dll, and voila! Got it working! *Sort of.

Warning: Spoiler! [ Click to expand ]


The thing is that it's so "OMG" tricky - the cars keep showing up, disappearing and then reappearing under certain cam angles, but at least they actually show up now. Sometimes. :lol:
As alwasys thanks for the tip, @crosire!
Last Edit: 5 months 13 hours ago by polyneutron. Reason: The issue was solved
The administrator has disabled public write access.