ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load

More
5 years 11 months ago #1 by Plutonian1984 ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load was created by Plutonian1984
I installed ReShade 3.0 to SpaceEngine 0.98, and upon startups and reloads, at least five shaders will be unable to load due to a compile error, but otherwise runs flawlessly. The problem shaders are AdaptiveSharpen, Emphasize, FXAA, LumaSharpen, and Vignette.

Here's the log file. :)

[url] drive.google.com/file/d/0B1C6RbksuFXSUWh...3c/view?usp=drivesdk [/url]

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #2 by crosire Replied by crosire on topic ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load
Eh. I kind of missed this post. In case you are still around, does this happen with 3.0.4 as well?

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #3 by Plutonian1984 Replied by Plutonian1984 on topic ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load
Apparently I missed the reply, too. :S

Anyways, I apologize for my lateness and thread bump, but I just downloaded 3.0.6, and the issue persists. Looking at the opengl32.log, I see numerous errors, covering the second half of the log. Since I have better internet access than 4 months ago when I first posted, I opted to download the additional shaders at the end of setup.

drive.google.com/file/d/0B1C6RbksuFXSUGZ...dkE/view?usp=sharing

EDIT: Also, I am on Intel HD 4400. I updated my graphics drivers, but no change, still having the errors.
Last edit: 5 years 7 months ago by Plutonian1984. Reason: Forgot to add Graphics Card details.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #4 by crosire Replied by crosire on topic ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load
Ah. Intel's GLSL compiler cannot handle ReShade's GLSL output apparently. That's a common thing since NVIDIA, AMD and Intel all have their own GLSL compilers, each more or less restrict on syntax. NVIDIA is very lax, so shaders that compile there don't necessarily compile on AMD or Intel. Since I'm developing on a NVIDIA machine it can happen that ReShade produces GLSL only NVIDIA can compile and it's hard to reproduce other cases.
The following user(s) said Thank You: Plutonian1984

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #5 by amoebae Replied by amoebae on topic ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load
I've got a Space Engine problem too.

I'm using SE 0.9.8.0 with ReShade 3.0.6. All my planet and star textures are invisible - everything else renders as it should. If I remove ReShade everything shows up fine.

So, a shader conflict? I've done a fresh install of Space Engine, but no dice.

I don't have the problem Plutonian had - I've had no compilation errors on load. I didn't have this problem with an earlier 2.x version of ReShade. This is the first time I've tried a 3.x version with it.

Edit: I've removed the shaders, so it's just loading ReShade on its own - and still the same thing. I've also tried 3.0.5 - same again. Really odd.
Last edit: 5 years 6 months ago by amoebae.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #6 by amoebae Replied by amoebae on topic ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load
Okay, 3.0.3 works fine. I don't have 3.0.4 so I don't know where the borkedness was introduced.

So, with ReShade 3.0.5 and 3.0.6 I get no planet/star textures in Space Engine 0.9.8.0.

With ReShade 3.0.3 I do. Will stick with that version for now, but would be interested to know what happened to cause the weirdness.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #7 by JeremiePlam Replied by JeremiePlam on topic ReShade 3.0, SpaceEngine 0.98; Shaders Won't Load
How did you download other versions?
I have the same "transparency problem"

EDIT: Never mind found them on another forum

For people looking for them here they are: reshade.me/forum/general-discussion/294-...-repository-new-host
Last edit: 5 years 6 months ago by JeremiePlam.

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.