Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] No Man's Sky and Elite stopped working with 3.0

No Man's Sky and Elite stopped working with 3.0 2 years 1 month ago #1

First of all hello to everyone and thanks crosire. Your tool is ESSENTIAL to 21st Century videogaming.

As the title says, can't launch neither of those games.

NMS worked up until 3.0.1, then it stopped launching. Now it won't work with 3.0.1 anymore, probably due to updated shaders.
ReShade 1.1.0 with SweetFX 2.0 is the only feasable solution atm.

Is it something that can be looked into?

Cheers and keep up the fantastic work :)
Last Edit: 2 years 1 month ago by Trinchero.
The administrator has disabled public write access.

No Man's Sky and Elite stopped working with 3.0 2 years 1 month ago #2

Is the same true with 3.0.4?
Cheers, crosire =)
The administrator has disabled public write access.

No Man's Sky and Elite stopped working with 3.0 2 years 1 month ago #3

thanks for your prompt reply, crosire.

Still no go with 3.0.4. Tried 10 minutes ago.
The administrator has disabled public write access.

No Man's Sky and Elite stopped working with 3.0 2 years 1 month ago #4

3.0.4 is working for me on No Man's Sky, just gives warning "error compiling"

Edit: warning goes away after removing FXAA from the shader folder, Reshade then works fine, so FXAA is the problem
Last Edit: 2 years 1 month ago by Gar Stazi.
The administrator has disabled public write access.

No Man's Sky and Elite stopped working with 3.0 2 years 1 month ago #5

Had the error compiling message since 3.0, but the game loaded regardless.

After that, one day NMS simply decided to stop loading with Reshade 3.0 installed.

I've since then tried everything:
clearing all game's caches, checking file integrity through Steam, deleting unwanted shaders from Reshade game folder, INCLUDING FXAA.
Nothing worked.

I don't think the FXAA shader is the culprit.
The game simply fails to load with 3.0.

Perhaps the fault lies in the new injection method, because ReShade 1.1.0 with SweetFX 2.0 works just fine.
Last Edit: 2 years 1 month ago by Trinchero.
The administrator has disabled public write access.

UPDATE 2 years 1 month ago #6

UPDATE: I got it working. Here is what I did, couldn't be certain as to what of the following steps fixed it, but I'd be keen to suppose its the game's dll's.
Perhaps crosire can shed some light.

1st - deleted the four dll's in the game's 'Binaries' folder (libSceFios2, Ninja_x64_Release, ProfanityFilter_x64_v120, steam_api64) and let Steam download them again

2nd - went into NMS.exe Compatibility tab and ticked 'Run this program as an administrator' then into Security tab and set Permissions for Authenticated Users to Full control

3rd - installed ReShade 3.0.4, launched game and loaded desired shaders successfully.

Still haven't tried Elite: Dangerous with 3.0.4. Will do and report here.
Last Edit: 2 years 1 month ago by Trinchero.
The administrator has disabled public write access.

UPDATE 2 years 1 month ago #7

Elite: Dangerous works flawlessly on ReShade 3.0.4 without any shader loading issues. Depth buffer is reversed though.
Still missing some shaders however like the SweetFX Reinhard shader for example. Other than that, awesome!
The administrator has disabled public write access.

UPDATE 2 years 1 month ago #8

UPDATE: Elite. Dangerous does indeed work fine with 3.0.4, while NMS exhibits VERY ODD behaviour.
Suddenly the game can decide not to start at all with ReShade installed.
It can work perfectly for one session, closing the game and restarting it more than once with no problem whatsoever, running flawlessly with shaders active.
The next day for some odd reason it doesn't launch UNLESS I completely remove ReShade, and then it's a painstaking trial and error attempt before I can get it back running again TOGETHER WITH ReShade, removing and redownloading game files hoping to nail the culprit.
Maybe it has to do with how the shaders are injected, perhaps a timing or initialization problem of some sort.
I must point out that I'm only using SMAA, Vibrance and LumaSharpen.

Crosire, anyone?
Last Edit: 2 years 1 month ago by Trinchero.
The administrator has disabled public write access.

No Man's Sky and Elite stopped working with 3.0 2 years 1 week ago #9

crosire wrote:
Is the same true with 3.0.4?

Same thing here.
I see only the sky, nothing else is rendered.
v.3.0.5

Edited: Everything worked perfectly when I applied ReShade 2.03
Last Edit: 2 years 1 week ago by WalterDasTrevas.
The administrator has disabled public write access.

No Man's Sky and Elite stopped working with 3.0 4 months 2 weeks ago #10

I initially tried everything under the sun to get this game working with reshade, to no avail. But someone named BlueSky on the No Man's Sky modding discord helped me get reshade finally working with this game. We both have laptops with integrated graphics cards and a secondary (real) graphics card, the GTX ones. He told me to disable my integrated graphics card from Device Manager.

IT WORKED!

Doing this will probably mess up your display otherwise, but it's only temporary. I got mine back to normal in under a minute. I'm just trying to figure out what I did exactly. In the meantime, you have a temp fix to use reshade with this game, almost guaranteed, probably.
The administrator has disabled public write access.