Reshade 3.05 doesn't work with Kingdoms of Amalur

  • Posts: 2
3 years 4 months ago - 3 years 4 months ago #1 by Lytche
Hi,
Is there a way to download 3.04? I don't see legacy/previous versions anywhere on this site.

I tried installing reshade 3.05 with Amalur but it does not work - the game freezes on the splashscreen indefinitely.
Installing it with no shaders have same end result.

There was a topic on the forum that it did not work with 3.03, but worked with 3.04, so my guess is it must have something to do with thread synchronization to hook installation, which I think was removed in 3.04 and brought back to 3.05.

LOG
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

  • Posts: 8
3 years 1 month ago #2 by Emanon
With each update more and more games are broken/unplayable with reshade, you fix one and break another. Reshade needs to change, this is an endless cycle.

Dragon Ball Xenoverse, Dead Space, Kingdoms of Amalur, among others are said to have perfect support on "Games" yet they don't work properly. Using the old and lost Reshade versions available online (like really old, before the in-game overlay) has been the only solution.

Please Log in or Create an account to join the conversation.