Welcome, Guest.
Username: Password: Remember me

TOPIC: UI doesn't start in Guild Wars 2

UI doesn't start in Guild Wars 2 1 year 1 month ago #1

Hi everyone,

I'm brand new here, so sorry for my lack of knowledge

I'm playing Guild Wars 2 for a few months now and I wanted to improve the look of the game, so I installed ReShade today, therefore the latest version. Everything seemed to go well, I chose the launcher, D3D9 (as it's stated in the Games section of this website (shame that this game isn't using D3D11 by the way)), I chose to downlad the shaders ReShade advise me to download automatically, and no error message nor anything.

So I close the installation window, start Guild Wars 2, but when I press Shift+F2 nothing happens, have I missed something, did I do something wrong ?

I searched for something similar on the forum, but found nothing, can someone help me please ?

Thanks in advance ;)

PS : If it may help, I'm using Windows 10 x64 build 16257.rs3, all the latest drivers on my computer (i7 6700HQ, GTX960m and 16Go of RAM)
The bird of the Hermes is my name, eating my wings to make me tame.
Last Edit: 1 year 1 month ago by Pieryck.
The administrator has disabled public write access.

UI doesn't start in Guild Wars 2 1 year 1 month ago #2

The administrator has disabled public write access.
The following user(s) said Thank You: Pieryck

UI doesn't start in Guild Wars 2 1 year 4 weeks ago #3

I can't get ReShade working with GW2, either. I've put the reshade-shaders folder, d3d9.dll and d3d9.ini into the bin64 folder as required, but it still won't hook in to the game. I've even tried repairing the game and installing ReShade fresh or used older versions. I'm at my wits end here. What sort of other programs might interfere with ReShade's ability to hook into a game?
The administrator has disabled public write access.
The following user(s) said Thank You: katu

UI doesn't start in Guild Wars 2 1 year 2 weeks ago #4

I, too, had issues. Following the YouTube guide didn't help.

When I placed the d3d9.dll file into the bin64 folder, the game threw a Dx9 error. "Unable to initialize 3D output. Verify that you have dx9 and an updated video driver." And if I left it in the Guild Wars 2 folder (or have a copy in each folder), then Shift+F2 brought up nothing ingame.

To try to fix this, I:
- did a fresh install of ReShade twice
- Updated my video card drivers
- Reinstalled dx9

However, it wasn't until I updated my video card drivers (geforce gtx 970) with all the extra stuff (3D vision etc) that it actually worked. From there, the YouTube vid helped.
The administrator has disabled public write access.

UI doesn't start in Guild Wars 2 1 year 2 weeks ago #5

Okay, so I'm back! And it's because while ReShade worked just fine all day yesterday, today I'm having the exact same issue, where attempting to start the game results in a DirectX error. I'm attempting to repeat my steps (I did shut down my computer last night, so maybe that did something?), but if I have to reinstall my graphics drivers every time in order to play, that's gonna be a problem for me.
The administrator has disabled public write access.

UI doesn't start in Guild Wars 2 1 year 2 weeks ago #6

Reinstalling dx9 did nothing. Reinstalling video drivers did nothing. Reinstalling ReShade did nothing.

I managed to get it to work by deleting "GW2TA370.tmp" in Appdata/Local/Temp. I found that file by running the game's .exe in diagnostic mode.

No idea at this point if that's actually what fixed it, or the game just requires multiple tries to open.
The administrator has disabled public write access.

UI doesn't start in Guild Wars 2 1 year 2 weeks ago #7

"Thankfully" today, the same issue persisted. This time, I didn't do anything with my DirectX, my video card drivers, or my cache files (well, I did delete a cache file but it wasn't related to yesterday's fix). The game started normally after 3 failures.

Very much considering going back to the old version of ReShade, at this point.
The administrator has disabled public write access.