Welcome, Guest.
Username: Password: Remember me

TOPIC: Krater (bitsquid engine) not working in 3.2+

Krater (bitsquid engine) not working in 3.2+ 3 months 2 days ago #1

Greetings,

I have no luck with V3.2+ on the Steam version of Krater. v3.1.2 works just fine with one exception... the depth buffer can't be used. I suspect the new depth buffer access stuff in 3.2 may be the problem. A shame, because that is exactly what I was hoping to be able to use. See the linked .zip file for the following...

dxgi.log (v3.1.2 and v3.2.2)
Krater Console log (" " and " ")
dxgi.ini
Whatev.ini (settings, whatev)

Reshade v3.2.2 vs Krater on TinyUpload

Thanks for any help you can give me. Let me know if you need more info. Note that the Krater Console log for v3.2.2 is a crashdump and contains my system info, so please see that rather than me typing it all here.

Thanks,
Vern.
The administrator has disabled public write access.

Krater (bitsquid engine) not working in 3.2+ 2 months 3 weeks ago #2

Well, good news, it runs with v3.3.2, but bad news is, no dice on tapping into the depth buffer. I tried the new depth buffer access hack, and I get... strange things... like a view looking at me from a long distance away, or a depth buffer with only 1 unit as though it is his own personal one? There are only two different buffers to choose from, and using the Copy depth before clearing option is no good.
The administrator has disabled public write access.