Welcome, Guest.
Username: Password: Remember me

TOPIC: Shaders won't inject at certain resolution?!

Shaders won't inject at certain resolution?! 3 weeks 2 days ago #1

  • DE
  • DE's Avatar
  • Offline
Hi all,
the game at play is For Honor. At a resolution of 5120x2160, neither AO or DoF can be injected. At lower resolutions like 2880x1440, they show up how they are supposed to. Any explanation (and solution) to that?

Thx,
DE
The administrator has disabled public write access.

Shaders won't inject at certain resolution?! 3 weeks 2 days ago #2

Automatic depth buffer detection sometimes doesn't work at unusual resolutions. DOF and AO need access to depth buffer data, so they don't work if that fails. You can try and manually select a buffer on the DX11 tab.
Cheers, crosire =)
The administrator has disabled public write access.

Shaders won't inject at certain resolution?! 3 weeks 2 days ago #3

  • DE
  • DE's Avatar
  • Offline
What exactly do you mean by manually selecting a buffer? Is this some setting exclusive to ReShade 3? I am using ReShade 2.0.3f1 in which I have set the Depth Settings to being both logarithmic and reversed.
The problem with For Honor is that only this dxgi.dll of this ReShade version (and another one from one of the 1.x releases) works for me. Others won't let the game start because the game realises the additional .dll which Ubisoft probably think is inserted to cheat or something.
Last Edit: 3 weeks 2 days ago by DE.
The administrator has disabled public write access.

Shaders won't inject at certain resolution?! 3 weeks 1 day ago #4

Yeah that's EAC or Easy Anti Cheat blacklisting ReShade .dll by a per file or version but leaving some of the olders alone so these do work though the online check might still kick in and disable depth access when it registers network traffic.
The administrator has disabled public write access.

Shaders won't inject at certain resolution?! 3 weeks 1 day ago #5

And you need ReShade 3 to be able to overwrite automatic depth buffer detection, so looks like you are out of luck.
Cheers, crosire =)
The administrator has disabled public write access.