Welcome, Guest.
Username: Password: Remember me

TOPIC: No Man's Sky Won't Launch w/ReShade

No Man's Sky Won't Launch w/ReShade 1 month 4 weeks ago #1

Hey all,

Has anyone found a way to make No Man's Sky work with reshade? My understanding is that it used to work but stopped at some point, I just bought the game for that big Next update that just dropped yesterday. I usually know all the tricks to get resahde to work with games, but this is my first time coming across an OpenGL one. Drivers are up to date.

For reference, I've tried:

1) Installing reshade 3.0.8 through 3.4.0, all CTD on launch, with the game set to borderless-window mode (which I have to do with every game basically)
2) Doing the above, while also deleting the game's SHADERCACHE folder before running the game, as some reshade authors use to advise, though most presets are a year old or so, it seems.
3) For the hell of it, I renamed opengl32 files to d3d11 (and d3d9) just to see what would happen, since I usually have to rename the files from dxgi to d3d11 for my games to launch... game just doesn't pick up reshade when I do this, as expected, lol
4) Renamed opengl32 files to dxgi, again, just to see how things went down. Interestingly, the reshade files seem to still be picked up even though they aren't named opengl32 anymore, since the game CTD's before launching again. Epic.
5) Tried the above while having most of the effects disabled in the game, like having all anti-aliasing off and vsync off, all of the non texture-based and special effects settings, I believe. Still CTD before launch.

I think that's everything. After trying to do this since last night, I'm frustrated and sorry I bought the game. I CAN'T play PC games without being able to reshade them anymore. I know it shouldn't be this big a deal, but I just can't, lol. I basically only buy games to see how I can tinker with them for ReShade and I always release my presets on Nexus (I'm TheMercsAssassin on there and Youtube) or TheLazy. I have an addiction, please help me feed it, I'd be forever grateful.

Thanks so much,
Merc
Last Edit: 1 month 4 weeks ago by AssassinsDecree.
The administrator has disabled public write access.

No Man's Sky Won't Launch w/ReShade 1 month 4 weeks ago #2

It does actually work, I was playing NEXT with Reshade 3.4 last night.

However I also remember the crashing issues you speak of -- not from NEXT but from when I installed NMS when I purchased it two years ago. Unfortunately I don't remember how I solved this, but yes it was frustrating as all buggery. It may be loading it as Fullscreen, not using borderless window. I need to use exclusive fullscreen for all my games for SLI to work, so I'm pretty used to fixing up this borderless windows shenanigans games default to these days. It -may- also have had something to do with multi-monitors, which I also had, back in the day just in case you're using more than one.

FWIW here is the Reshade log showing it load. Note there are shader compiler errors for some shaders I get whenever loading Reshade as opengl32, I've been meaning to follow up with Crosire about this as all the shaders load fine in D3D. I use a single shader repository that all games load the shaders from. Once it gets to compiling shaders, Reshade has loaded.

Warning: Spoiler! [ Click to expand ]

*sigh* ok pasting the log has some sort of character limit. It stop as the above.
Last Edit: 1 month 4 weeks ago by Martigen.
The administrator has disabled public write access.

No Man's Sky Won't Launch w/ReShade 1 month 4 weeks ago #3

Thank you so much for responding! This gives me some level of hope. I do usually have to put all games in borderless windowed mode for reshade or they CTD on launch. But I'll definitely try it with fullscreen and see what happens. I'm at my wits end with trying different things, so anything new is super welcome! Must be something in my setup that is incompatible somehow.

Perhaps it matters that I'm using a laptop with the Nvidia Graphics AMP, which just lets me use a desktop card instead of a laptop card, not exactly like SLI where you get to use two GPUs (right?). Cheers!
The administrator has disabled public write access.

No Man's Sky Won't Launch w/ReShade 1 month 4 weeks ago #4

Darn, nothing. Tried all the combinations again of what I did before but with fullscreen enabled, and unfortunately nada. My best hope now is for Nvidia or Hello Games to add the game for NVIDIA freestyle support. Really, all I want is Depth of Field (autofocusing preferably), some sharpening, and the letterboxboxing I can toggle on and off that is the same size as the letterboxing the game uses for milestones and reaching new systems, etc. The game is really a looker.
The administrator has disabled public write access.

No Man's Sky Won't Launch w/ReShade 1 month 4 weeks ago #5

You have an external GPU? That might play a part I guess. Does NMS load if you unplug that and use the internal (intel) GPU? At least as a test.

Also, FWIW here's my TKGRAPHICSSETTINGS.MXML from the Binaries/SETTINGS directory. Edit for your RES and just see if it loads. Perhaps there's a setting in yours that's playing up. Edit: Also remove the second monitor listed.
<?xml version="1.0" encoding="utf-8"?>
<Data template="TkGraphicsSettings">
	<Property name="Version" value="2" />
	<Property name="FullScreen" value="true" />
	<Property name="Borderless" value="false" />
	<Property name="Monitor" value="0" />
	<Property name="MonitorNames">
		<Property name="MonitorNames_00" value="0|NVIDIA GeForce GTX 1080 Ti|Generic PnP Monitor" />
		<Property name="MonitorNames_01" value="1|NVIDIA GeForce GTX 1080 Ti|Generic PnP Monitor" />
	</Property>
	<Property name="UseScreenResolution" value="true" />
	<Property name="ResolutionWidth" value="3440" />
	<Property name="ResolutionHeight" value="1440" />
	<Property name="VsyncEx" value="On" />
	<Property name="GSync" value="false" />
	<Property name="ShadowDetail" value="Normal" />
	<Property name="TextureDetail" value="Ultra" />
	<Property name="GenerationDetail" value="Normal" />
	<Property name="ReflectionsQuality" value="Normal" />
	<Property name="AntiAliasingEx2" value="TAA" />
	<Property name="MotionBlurQuality" value="High" />
	<Property name="MotionBlurStrength" value="180.000000" />
	<Property name="AnisotropyLevel" value="16" />
	<Property name="FoVOnFoot" value="100.000000" />
	<Property name="FoVInShip" value="100.000000" />
	<Property name="Brightness" value="128" />
	<Property name="MaxframeRate" value="110" />
	<Property name="NumHighThreads" value="3" />
	<Property name="NumLowThreads" value="6" />
	<Property name="TextureStreamingEx" value="Off" />
	<Property name="TexturePageSizeKb" value="8192" />
	<Property name="ShowRequirementsWarnings" value="true" />
	<Property name="RemoveBaseBuildingRestrictions" value="false" />
	<Property name="BaseBuildingLimit" value="2000" />
	<Property name="MouseClickSpeedMultiplier" value="0.500000" />
	<Property name="AmbientOcclusion" value="HBAO" />
	<Property name="UseHDR" value="true" />
	<Property name="UseLightshafts" value="true" />
	<Property name="TerrainQualityEx" value="High" />
	<Property name="UseTerrainTextureCache" value="false" />
	<Property name="UseArbSparseTexture" value="false" />
	<Property name="EnableTessellation" value="false" />
</Data>
One last thing to try -- disable Windows 10's retarded fullscreen optimizations. Here's the settings I'm using (registry edit) in this thread on Guru3D:

forums.guru3d.com/threads/geforce-397-31...page-14#post-5544324

You may find other posts in that thread helpful too.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

No Man's Sky Won't Launch w/ReShade 1 month 3 weeks ago #6

I also got no mans sky NEXT to run with Reshade 3.4, but it wouldn't run at first. My NMS folder had reshade 3.2.1 in it from the last time i played it before downloading NEXT, so i downloaded reshade 3.4, and it still didn't run.

I'm not sure what fixed it, but i did clear out the no mans sky shadercache (and disabled Nvidia shadercache for no mans sky in nvidia inspector), plus disabling all win10 fullscreen optimizations. I also think i had to run it like twice in fullscreen without reshade (the first time after i reopened, it was windowed with a titlebar for some reason), then it would load with reshade.

I noticed the game will load with reshade 3.4, but not with 3.2.1 (i tried putting back the old opengl32.dll i had to see if i could fix one of the shader compiler errors, and the game refuses to open.) Interestingly, as a sidenote, it appears reshade 3.4 does not like a shader that worked fine in 3.1 and 3.2. I get the following error:

error C7011: implicit cast from "float" to "bool"

From this shader by Ioxa: Bloom with depth mask test which was originally from post #50 here: reshade.me/forum/shader-presentation/270...e-3-0?start=40#21819

I figured it the issue with the older reshade not working, plus the newer one throwing the error, is all due to No Man's Sky's specific OpenGL version and coding, lol. All the standard shaders are fine though, including depth based ones.

Edit: I got it working by modifying 2 lines (Around line 268):

if( NearCutoff || FarCutoff < 100.0) needs to be changed to: if( NearCutoff != 0 || FarCutoff < 100.0)

and a couple lines down:

if(NearCutoff) changes to if(NearCutoff !=0)
Last Edit: 1 month 3 weeks ago by sajittarius.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

No Man's Sky Won't Launch w/ReShade 1 month 3 weeks ago #7

I'm one of those people who cannot get it to work no matter what i try. I've literally done every thing I can find on the net to get it to run but it just acts like its going to launch and then force stops the launch of the game. I've tried different versions , even trying the 64x sweetfx using radeon pro to see if I could bypass. I tried the old framework 1.2 shaders to see if it was an anti cheat flagging but it still crashed. DXGI D3D11 D3D9 OPENGL32 , nothing works. Deleted the shader cache, disabled full screen optimizations for windows, nothing works. Something that I been wondering might be causing the crash is optimus. I run a 880m with optimus and though I use nvidia inspector/control panel to make sure games are running with the 880m I wonder if the duel gpu might be the main culprit.



EDIT-IMPORTANT: After testing I have been able to figure out exactly whats going on at least with my system loading. I changed the graphics card in nvidia settings to load no mans sky with the intel 4600 instead of my 880m and reshade loaded right up with no issues. My chip couldnt run no mans sky though, instead it just locked up crashing my system. So yes for sure its the duel card causing the issues with no mans sky/reshade combo. Im going to continue trouble shooting this now that I isolated the issue and will update this if I can figure out if there is a workaround.
Last Edit: 1 month 3 weeks ago by cronius77.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

No Man's Sky Won't Launch w/ReShade 1 month 3 weeks ago #8

@cronius77 You're right, the dual cards is the issue. The below should help you get around the issue.

I initially tried everything under the sun to get this game working with reshade, to no avail. But someone named BlueStar on the No Man's Sky modding discord helped me get reshade finally working with this game. We both have laptops with integrated graphics cards and a secondary (real) graphics card, the GTX one. He told me to disable my integrated graphics card from Device Manager.

IT WORKED!

Doing this will probably mess up your display otherwise, but it's only temporary. I got mine back to normal in under a minute. I'm just trying to figure out what I did exactly. In the meantime, you have a temp fix to use reshade with this game, almost guaranteed, probably.
Last Edit: 1 month 3 weeks ago by AssassinsDecree. Reason: had BlueSky instead of BlueStar
The administrator has disabled public write access.

No Man's Sky Won't Launch w/ReShade 1 month 1 week ago #9

I had No Man's Sky Next crash with Reshade as well. Turns out some Shader(s) were causing the crash; deleting all but Shaders I wanted resolved the Issue.
The administrator has disabled public write access.