Welcome, Guest.
Username: Password: Remember me

TOPIC: Crysis GOG release doesn't work with Reshade

Crysis GOG release doesn't work with Reshade 3 months 1 week ago #1

The GOG release doesn't work with ReShade, if I launch it in DirectX10 32 Bit (which is the default API) it works but will not work with anything that uses depth buffer, on the other hand, if I force the 32bit executable to run in DirectX9 mode, it simply won't launch as long as the d3d9.dll from Reshade is present. The 64bit exe from Crysis doesn't let Reshade hook to it at all. What are my options here?
The administrator has disabled public write access.

Crysis GOG release doesn't work with Reshade 3 months 1 week ago #2

romulus_ut3 wrote:
The GOG release doesn't work with ReShade, if I launch it in DirectX10 32 Bit (which is the default API) it works but will not work with anything that uses depth buffer, on the other hand, if I force the 32bit executable to run in DirectX9 mode, it simply won't launch as long as the d3d9.dll from Reshade is present. The 64bit exe from Crysis doesn't let Reshade hook to it at all. What are my options here?

hy,

someone allready asked teh same in the GoG forum where also someone posted that it works.

www.gog.com/forum/crysis_series/have_you..._able_to_use_reshade

ill quote from it:
It works for me. You could try to add the ReShade dll manually. Pressing STRG while clicking the button to choose the game executable, two dlls should show up in the current folder. Rename ReShade64.dll to dxgi.dll and place it in your bin64-directory.

try that and see if it works, im pretty shure it has to, since i played it with reshade some month ago...

greetz
The administrator has disabled public write access.

Crysis GOG release doesn't work with Reshade 3 months 6 days ago #3

That solution is no longer useable as Reshade no longer uses dll files with names like Reshade.dll or Reshade64.dll
The administrator has disabled public write access.

Crysis GOG release doesn't work with Reshade 3 months 6 days ago #4

romulus_ut3 wrote:
That solution is no longer useable as Reshade no longer uses dll files with names like Reshade.dll or Reshade64.dll

:huh: ummm, not shure what you mean, but when i press STRG and klick install i get 2 DLL files.

ReShade64.dll
ReShade32.dll

wich i then can use and rename to what i need. ReShade64.dll --> dxgi.dll and then put it in the crysis folder where the EXE is.

Edit:

im reinstalling Crysis GoG again and will test it, but im 1000000000% shure that it works, since it worked a few month ago..

EDIT2:

Here you go, Crysis 64bit / DX10 (gog) with reshade and depth buffer:

Last Edit: 3 months 6 days ago by BeTa.
The administrator has disabled public write access.

Crysis GOG release doesn't work with Reshade 3 months 4 days ago #5

Are you using Reshade 4.0.3 by Crosire?

Downloading this fix from this discussion helped me to get things working again:

reshade.me/forum/general-discussion/4766...issue?start=20#34440
Last Edit: 3 months 4 days ago by romulus_ut3.
The administrator has disabled public write access.