Welcome, Guest.
Username: Password: Remember me

TOPIC: Only keyboard input allow

Only keyboard input allow 2 months 2 weeks ago #1

Hey guys, is it possible to only let keyboard input to control the menu? I'm currently trying to find best settings for Asetto Corsa but my G27 wheel axis keep interrupting and make changing settings quite a hassle or nearly impossible.
The administrator has disabled public write access.

Only keyboard input allow 2 months 2 weeks ago #2

Keyboard controls in ReShade menu:
Arrow keys: Move
Spacebar: Confirm (jump into a widget)
Esc button: Undo (jump out a widget)
Ctrl + Tab: Switch tabs
Cheers, crosire =)
The administrator has disabled public write access.

Only keyboard input allow 2 months 2 weeks ago #3

crosire wrote:
Keyboard controls in ReShade menu:
Arrow keys: Move
Spacebar: Confirm (jump into a widget)
Esc button: Undo (jump out a widget)
Ctrl + Tab: Switch tabs
Thanks for the quick reply sir, my problem is actually related to Reshade picking up my G27 input (G27 pedals start at 100% input)

I recorded a video showing the issue i'm having.


As shown, i'm having hard time to change any value. I know unplugging the wheel will "solved" this problem but i wonder if it possible to make Reshade ignore other xinput and only pick keyboard input?
Last Edit: 2 months 2 weeks ago by xAcid9.
The administrator has disabled public write access.

Only keyboard input allow 2 weeks 5 days ago #4

ReShade doesn't pick up XInput. What is happening is that for whatever reason Assetto Corsa fakes an "arrow up" key down event, but never sends a key up event afterwards, so ReShade thinks the "arrow up" key is down indefinitely.
Fixed now in github.com/crosire/reshade/commit/2cbdd1...75e8cf9b3fb8d2f3a1a2.
Cheers, crosire =)
Last Edit: 2 weeks 5 days ago by crosire.
The administrator has disabled public write access.