Welcome, Guest.
Username: Password: Remember me

TOPIC: ReShade with nGlide Vulkan

ReShade with nGlide Vulkan 1 month 8 hours ago #1

Hello,

I am trying to use ReShade with nGlide 2.0 to improve the appearance of an old flight sim, Joint Strike Fighter by Eidos.

If I set up nGlide to use DirectX and install ReShade set to DirectX, I do see the ReShade UI appear when I enter the game. However, the game crashes to desktop after only a few seconds of play time. This happens whether or not I am using ReShade (at lower resolutions it seems more stable, but the frame rate can be poor at times even on my modern RTX 2080 + i7-8700k rig... plus I'd rather play at high res).

If I set up nGlide to use Vulkan, JSF runs great at high resolution and seems very stable. However, if I install ReShade for the game and select Vulkan, it doesn't seem to inject into the game.

I've made sure to uninstall DirectX ReShade for the game before installing Vulkan ReShade, and in fact I actually selected Vulkan on my first installation since I had already determined that JSF runs better with nGlide using Vulkan.

Any ideas on what the issue could be?

This game uses software rendering when 3DFX is not enabled, btw (and is also unstable at high resolution this way). So using a Glide wrapper is my only option to play with stability at high res.
Last Edit: 1 month 8 hours ago by mb1685.
The administrator has disabled public write access.

ReShade with nGlide Vulkan 4 weeks 1 day ago #2

Couple of things, first off, have you tried setting Reshade to opengl instead of Vulkan?
Why, you may ask.
No Man's Sky is now Vulkan. However Reshade loads fine if opengl is selected instead.
No, I don't know why.
Secondly, getting Steam version NMS to run in Vulkan proved..problematical at first.
Crosire said something about the client launcher having to have Reshade injected to it.

Now I don't know anything about nGlide, but perhaps you could try installing Reshade to that instead.
The administrator has disabled public write access.
The following user(s) said Thank You: mb1685

ReShade with nGlide Vulkan 4 weeks 1 day ago #3

Got it working! Turns out all I had to do was turn off Compatibility Mode for the game executable. :)
The administrator has disabled public write access.