Welcome, Guest.
Username: Password: Remember me

TOPIC: Enabling MXAO in Mass Effect 2

Enabling MXAO in Mass Effect 2 1 month 1 day ago #1

Hi all,

First I want to say thank you for reshade as it has brought many older dx9 games to life!

As the title states, I am having trouble enabling MXAO in ME2. I have been reading results from people who have had success enabling MXAO but on my end O have no success. I've also tried to enable standard SSAO and out of luck.

ME2 does have a hidden setting AmbientOcclusion=True so I disabled that.
I also disabled AO through the NVInpector profile but no go. Lastly, under Reshade preproccesor I tapped the reverse algorithm to 0.

How do I access depth buffer with this game? I will note that I do have Gedosato for downscaling but I tried it without Gedosato and without. :-(

Thank you for any help you can provide and thanks!
The administrator has disabled public write access.

Enabling MXAO in Mass Effect 2 1 month 1 day ago #2

4.5.1 fixed depth buffer access in Mass Effect 2. Nothing special to do really, it just works. As always, check the DX9 tab for info on them. GeDoSaTo may mess all of that up of course.
Cheers, crosire =)
The administrator has disabled public write access.

Enabling MXAO in Mass Effect 2 1 month 1 day ago #3

Thanks for your reply. I downloaded the 4.5.1 reshade using just mxao from the rehade and also tried quints from github but I am still getting no response. I enabled the compatibility bits from NVinspector and enabled AO through that panel and it is still not working. Every other effect that I do enable works except mxao. I tried fiddling with just the reverse to 0 or 1 but I am seeing no change in game. I am on Windows 10 right now but this seems really tricky to get it working. I clicked the dx9 tab and I can see the depth buffers and draw cells operating. Also, I went to debug but the culling gives me a black screen and the AO/IL tab just give me a grey screen.

I am doing all this without Gedosato.
The administrator has disabled public write access.

Enabling MXAO in Mass Effect 2 1 month 1 day ago #4

You need to click on "Copy depth buffer before clear operation". That's what I mean by checking on the DX9 tab.
You should always find the correct settings with the DisplayDepth shader before trying any other shaders relying on depth.
Cheers, crosire =)
Last Edit: 1 month 1 day ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: XE007

Enabling MXAO in Mass Effect 2 1 month 11 hours ago #5

Thanks for your reply, got it sorted. Two questions, do you put Tridither at the top of the load order? I have LUT.fx at the top of my load order; should I place Tridither.fx before or after the LUT.fx?

Lastly, have Tridither in my load order, do I need Deband.fx since I read somewhere that Tridither is suppose to prevent it? I have Deband.fx at the bottom of my load order after all my effect and seem to do a good job.

This is my load order.
TechniqueSorting=LUT,HeatHaze,Tonemap,FilmicPass,MagicBloom,Curves,AdvancedCRT,CA,ChromaticAberration,AdaptiveSharpen,TriDither,Deband,Scanlinebs

Thanks for any help.
Last Edit: 1 month 11 hours ago by XE007.
The administrator has disabled public write access.