ReShade doesn't appear on taken screenshots-Vulkan

  • Posts: 2
1 month 2 weeks ago #1 by Jacob Darka
Hello,

As I'm saying in the title, when I take a screenshot using steam, bandicam, etc..., the effects of the ReShade doesn't appear on them, as if I disabled the reshade before taking them, I tried taking a screenshot on Red Dead Redemption 2 [Vulkan], The Surge 2, and it's the same issue.

Apparently it's a Vulkan-related issue, because when I switched to DX12 API in RDR2, the reshade appears as usual in the pics, however, a game like The Surge 2 uses Vulkan API only, therefore, the taken screenshots appear as original only.
Note: taking a SS using reshade's built-in screenshot feature, the effects appear normally on the SS, however, I prefer using other methods to take them.

So, how can I fix this issue, and be able to take screenshots with reshade enabled in vulkan-games, like in dx11/dx12-games??

Please Log in or Create an account to join the conversation.

  • Posts: 3638
1 month 2 weeks ago #2 by crosire
That's just how Vulkan layers work. Either Steam/... layer is before ReShade layer or after it and depending on that it captures ReShade or does not. You would have to change the Vulkan layer order and this is not trivial. But it is entirely normal behavior and not a bug.

Please Log in or Create an account to join the conversation.

  • Posts: 2
1 month 2 weeks ago #3 by Jacob Darka
I understand, "You would have to change the Vulkan layer order and this is not trivial.", how may I change the layer order? or this is a developer-related thing?

Please Log in or Create an account to join the conversation.