[SOLVED] Expected Reshade archives to contain reshade dlls

  • Posts: 7
1 month 3 days ago #1 by DieuDeGlace
So im trying to compile again, and when I get to making the application without anny errors or any weird warnings it says installing reshade failed and gives me "Expected Reshade archives to contain Reshade dlls" if anyone has a solution or are able to help it would be greatly appreciated

Please Log in or Create an account to join the conversation.

  • Posts: 3727
1 month 3 days ago #2 by crosire
The setup you downloaded got corrupted (it is missing the actual ReShade files). Download it again. It's also possible that some anti virus software is interfering, although rather unlikely.
The following user(s) said Thank You: DieuDeGlace

Please Log in or Create an account to join the conversation.

  • Posts: 7
1 month 3 days ago - 1 month 3 days ago #3 by DieuDeGlace
gotcha, I just cloned the regular files from your repository and set the tags to 4.2.1 and it said there were dependency errors so I downloaded 4.2.1 separately and tried importing or replacing the dependencies. dunno if that's just an error on my behalf but yeah ill retry. but if I cant figure it out could you link me a mediafire with the main files I need? I have the project files and all so Idk what exactly im missing.

Please Log in or Create an account to join the conversation.

  • Posts: 3727
1 month 3 days ago - 1 month 3 days ago #4 by crosire
Ah, missed the first part, sorry.
To build you first need to build the "Release" target for both Win32 and x64 platforms and then the "Release Setup" target. The latter consumes the DLLs created by the former, hence why the former needs to be done first.

Also, all official ReShade releases are still available via their respective links, e.g.: www.reshade.me/downloads/ReShade_Setup_4.2.1.exe
You should always use the latest one though.
The following user(s) said Thank You: DieuDeGlace

Please Log in or Create an account to join the conversation.

  • Posts: 7
1 month 3 days ago #5 by DieuDeGlace
I would use latest version of reshade but the game im using seems to block any other version of 4.0 unless its 4.0.2, which ive messed with and its extremely buggy, or 4.2.1 which is more stable but has some dependency problems that I can easily fix. Thank you though for responding and helping me out some will definitely make sure I get it right this time!

Please Log in or Create an account to join the conversation.

  • Posts: 7
1 month 3 days ago - 1 month 3 days ago #6 by DieuDeGlace
yup got it to work. I had to reclone because I noticed some stuff missing compared to the regular 4.2.1 files were missing and I was able to build both 32bit and 64bit successfully. Though I am sad to see the 4.2.1 that I built was blocked by battleye on the crew 2 which I don't think ill be able to fix unless I get it whitelisted somehow. I would've used the release version you have but I want raytracing on the game and so I removed network detectors but even with network detectors on it was still blocked so its a shame, but again thanks for helping me though this!

Please Log in or Create an account to join the conversation.