Setup doesn't allow me to select a rendering API (Star Wars: The Old Republic)!

More
2 years 6 months ago - 2 years 6 months ago #1 by Loftmark Setup doesn't allow me to select a rendering API (Star Wars: The Old Republic)! was created by Loftmark
Hello everyone,

I recently bought a new computer and decided to re-install some of my favorite games. I tried ReShade in pretty much all of them and it worked just fine. Except for one of the titles, Star Wars: The Old Republic.

Whenever I run the ReShade Setup and select SWTOR, the installer will skip right to the presets and will automatically select "Direct3D 10/11/12". Even though it works, a large amount of in-game effects and textures disappear. The game becomes unstable. No matter how many times I try to re-install this app, it will ALWAYS select this Direct3D option. SWTOR is "Good" in the compatibility list and the tutorials I found online showed no issues... so I don't know what I'm doing wrong.

I tried reaching out for help in the Discord, and an user told me to rename files. Renaming them either had ReShade stop working as a whole or kept the game from booting up.

Anyone who could lend me a hand?
Last edit: 2 years 6 months ago by Loftmark.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #2 by crosire Replied by crosire on topic Setup doesn't allow me to select a rendering API (Star Wars: The Old Republic)!
The setup knows this is the only option to get ReShade working in SWTOR at all, so it chooses automatically und does not let you do it yourself.

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.