Compatibility list

More
3 years 4 months ago #621 by cloud6625
Replied by cloud6625 on topic Compatibility list
dxgi.dll

A Hat In Time works with reshade 3.1.0. No depth buffer, and crashes on startup with d3d9.dll.

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #622 by FYKC
Replied by FYKC on topic Compatibility list
The Elder Scrolls III: Morrowind
[Reshade 3.1.0 - d3d9.dll]
Works. No depth buffer.

Note: Morrowind Graphics Extender (MGE) is required to be installed for Reshade to work. Reshade will say you need to install d3d8to9--DO NOT USE--it will break MGE and subsequently Reshade. Manually install Reshade (ctrl-click d3d9 when choosing api) and everything will work as it should.
The following user(s) said Thank You: crosire, TarekJor

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #623 by bugmenot
Replied by bugmenot on topic Compatibility list

crosire wrote: As this was requested, here's a game compatibility list .
If you have a game that's not on the list, please answer this topic and tell your findings with it =)



Hello, can you update the list with the Game GRIM DAWN ?
Actually, it says :

Grim Dawn Direct3D 9 Perfect


But should now be

Grim Dawn Direct3D 10+ Perfect



A game update changed this :

V1.0.2.0

[Major New Features]

The game engine has received a major overhaul to its renderer, allowing the game to run on DirectX11. While results will vary from system to system, this will generally result in improved performance.


Thank you :)
The following user(s) said Thank You: crosire

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago - 3 years 3 months ago #624 by Uncle Crassius
Replied by Uncle Crassius on topic Compatibility list
Total War: Warhammer 1 works flawlessly with DX11 renamed to d3d11.dll . Ingame, turn off Anti Aliasing and Porthole Quality 3D for depth access, otherwise only the litte 3D character windows have depth. Tested with 3.1.1.

Edit: Working fine in TW:W2 as well.
Last edit: 3 years 3 months ago by Uncle Crassius.
The following user(s) said Thank You: crosire

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #625 by kaicooper
Replied by kaicooper on topic Compatibility list
Celeste

Reshade dosnt run with it at all..whatever u choose :(

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #626 by JBeckman
Replied by JBeckman on topic Compatibility list
Seems Squad and PUBG has decided to ban ReShade use for now due to what some of the shader effects allows for.
Squad has an article up here with a zoom shader demonstration. - joinsquad.com/readArticle?articleId=254

EDIT: It's not a game ban or anything, EAC which these programs use for anti-cheat solutions will simply crash on start. :)
(Though this could mean updated versions of EAC will now do the same in other games.)
Last edit: 3 years 2 months ago by JBeckman.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 5 days ago #627 by DeMondo
Replied by DeMondo on topic Compatibility list
Update: Game Compatibility List: Feb, 2018

RS3 depth buffer fully working ?:
[ yes ( RS3 + depth buffer ) // no ( no RS3 possible at all ) // partial ( RS3 is working but no depth buffer ) ]
[ ► extra: some fixes ]

- Crossout [ 64-bit DX11 // MMO ]: RS3 is working but no depth buffer [ ► alternative: use the awesome nVidia Freestyle shaders ]

- Dead Rising Remastered [ 64-bit DX11 // Game Engine: Multi-Thread Framework ]: yes

- Dear Esther [ 32-bit DX9.0c // Game Engine: Source ]: yes << ! >> [ ► Fix: disable MSAA & type "r_drawvgui 0" into the console to disable the UI. This works for nearly all Source Engine games ]

- Deus Ex - Mankind Divided [ 64-bit DX11 // Game Engine: Dawn Engine ]: yes << ! >> [ ► Fix: for Win 7: ReShade 3 is working: Use nVIDIA Display Driver 376.33 [ 14 Dec 2016 ] [ newer ones will cause a crash with ReShade ] & isnt working with v378.92+ // ► Rename ReShade64.dll -> d3d11.dll [ dxgi.dll will cause a crash ] // ► To skip the launcher AND the intro videos: Steam Launch Option: -benchmark // ► Fix: for Win 8+: use Win 7 Compatibility Mode ]

- Homefront 2 - The Revolution [ 64-bit DX11 // Game Engine: CryEngine (4th generation) ]: yes // ► 4k Fix: change desktop res. to 4k before booting up the game

- Homeworld: Deserts of Kharak 2 [ 64-bit DX11 // Game Engine: Unity ]: ReShade depth buffer: working with standard resolution // but not with 4k res. // ► Ultra Wide Res. Fix: change desktop res. ( like 4k ) before firing up the game

- Need for Speed [ 2016 ] [ 64-bit DX11 // Game Engine: Frostbite 3 ]: yes [ in offline mode ! ]

- Need for Speed Payback [ 2018 ] [ 64-bit DX11 // Game Engine: Frostbite 3 ]: yes [ in offline mode ! ]

- >observer_ [ 64-bit DX11 // Game Engine: UE4 ]: RS3 is working but no depth buffer

- Prey 2017 [ 64-bit DX11 // CryEngine (4th generation) ]: yes

- Sniper Ghost Warrior 3 [ 64-bit DX11 // Game Engine: CryEngine (4th generation) ]: yes

- theHunter: Call of the Wild [ 64-bit DX11 // Game Engine: Avalanche Apex ]: yes

- The Cursed Forest [ 64-bit DX11 // Game Engine: CryEngine (4th generation) ]: yes

- The Evil Within 2 [ 64-bit DX11 // Game Engine: STEM Engine ]: yes

- The Technomancer [ 64-bit DX11 // Game Engine: PhyreEngine ]: yes

- Watch Dogs 2 [ 64-bit DX11 // Game Engine: modified Disrupt Engine ]: RS3 isnt working at all [ ► alternative: use the awesome nVidia Freestyle shaders ] fix: see below

- Wolfenstein II: The New Colossus [ 64-bit Vulkan // Game Engine: id-Tech 6 ]: no RS possible due to Vulkan API [ ► alternative: use the awesome nVidia Freestyle shaders ]



Update: Game Compatibility: April 30, 2018

- Watch Dogs 2 [ 64-bit DX11 // Game Engine: modified Disrupt Engine ]

Reshade 3 Crash Fix:
use these launch parameters:
-disablepagefilecheck -eac_launcher -noIntroVideo -nologfile -nosplash

& Go offline

Reshade 3 depth buffer fully working with the fix [ used: Uplay version / RS 3.1.2 ]
Last edit: 3 years 5 days ago by DeMondo.
The following user(s) said Thank You: crosire, AssassinsDecree, TarekJor

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #628 by Uncle Crassius
Replied by Uncle Crassius on topic Compatibility list
Thalixte's improved depth detection works flawlessly with Far Cry 4, just tried it out. Dxgi, 64-bit. And, as you might've guessed, Far Cry: Primal works as well.
Last edit: 3 years 1 month ago by Uncle Crassius.
The following user(s) said Thank You: AssassinsDecree

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #629 by bobbydole
Replied by bobbydole on topic Compatibility list
Game: StarCraft: Remastered
Render API: OpenGL
Status: Crash

It is uses an OpenGL renderer (though they programmed a D3D9 renderer to fall back to in case OpenGL 2.1+ is not supported by the video card). It just gives the error message "The application encountered an unexpected error." when I try to launch it after installing ReShade. Tried both OpenGL and Direct3D 9, tried ENBInjector w/ ENBSeries.dll (it doesn't do anything, I think ENB only works in D3D9 anyway and there's no way to force Starcraft to use that renderer).
Last edit: 3 years 1 month ago by bobbydole.

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago - 3 years 3 weeks ago #630 by Uncle Crassius
Replied by Uncle Crassius on topic Compatibility list
Satellite Reign works with the official 3.1.2 release. Depth buffer access is restricted in Open GL, though. As the game offers a DX9 mode as well, use the respective dll. Depth buffer is not reversed but upside down.
Only issue: If you open the Reshade menu the camera will pan to the left automatically which can be annoying setting up shaders.
Last edit: 3 years 3 weeks ago by Uncle Crassius.

Please Log in or Create an account to join the conversation.

More
3 years 5 days ago #631 by DeMondo
Replied by DeMondo on topic Compatibility list
Update: Game Compatibility: April 30, 2018

- Watch Dogs 2 [ 64-bit DX11 // Game Engine: modified Disrupt Engine ]

Reshade 3 Crash Fix:
use these launch parameters:
-disablepagefilecheck -eac_launcher -noIntroVideo -nologfile -nosplash

& Go offline

Reshade 3 depth buffer fully working with the fix [ used: Uplay version / RS 3.1.2 ]
The following user(s) said Thank You: TarekJor

Please Log in or Create an account to join the conversation.

More
3 years 5 days ago - 3 years 5 days ago #632 by Sonny56
Replied by Sonny56 on topic Compatibility list
In the list of compatible games, simulator X-Plane 11 is having trouble closing. However, there are already several previous versions that this program has been presenting compatibility problems not allowing the game (X-Plane 11) to finish normally.
Last edit: 3 years 5 days ago by Sonny56.

Please Log in or Create an account to join the conversation.

More
3 years 5 days ago #633 by FYKC
Replied by FYKC on topic Compatibility list
Update for Morrowind:

Depth buffer is accessible with ReShade 3.2.2.

MGEXE required.
d3d9.dll

Please Log in or Create an account to join the conversation.

More
3 years 1 day ago #634 by sauhan77
Replied by sauhan77 on topic Compatibility list
there was n update to LA NOIRE in april, since then sadly reshade has stopped working... the game boots up normal, but no reshade msg or effect anymore.

Please Log in or Create an account to join the conversation.

More
2 years 10 months ago - 2 years 10 months ago #635 by ShoterXX
Replied by ShoterXX on topic Compatibility list
Half-Life 1, potentially all Gold Source games:
- Near perfect.
- Includes depth.
- Weird glitches with very specific shaders.
- Requires opengl32.dll file to be set as read-only, or the game will delete it on startup.
Last edit: 2 years 10 months ago by ShoterXX.

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago - 2 years 7 months ago #636 by Geneaux
Replied by Geneaux on topic Compatibility list
Prior to its Sep 5, Season 2 patch, Tekken 7 did work with Resahde 3.1.2 and up. I used the "OrdinaryTekken" Extreme preset over at NexusMods.

Now the game refuses to launch after the splash screen. Not sure what to do now.
Last edit: 2 years 7 months ago by Geneaux. Reason: Grammar

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #637 by Heroflex
Replied by Heroflex on topic Compatibility list
GTA IV compatibility is not Perfect, it's actually broken. I posted elsewhere in the forum about it but nobody has answered.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago - 2 years 6 months ago #638 by Kumbandit
Replied by Kumbandit on topic Compatibility list
Surprised it's not on the list yet, but here goes:
Far Cry 5 (game ver 1.2) - works perfectly, hook is 64-bit dxgi, version 3.4.1.351, depth buffer requires RESHADE_DEPTH_INPUT_IS_REVERSED=1 under settings and "copy depth before clearing" ticked under DX11 submenu(s), in-game AA shaders (SMAA and TAA) don't break the depth access at all
Last edit: 2 years 6 months ago by Kumbandit.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #639 by DeMondo
Replied by DeMondo on topic Compatibility list
HITMAN 2 [ 2018 / great game ]: perfect compatibility [ incl full depth buffer access ]

ReShade 4.0.2
dx11 64-bit

RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0
-->> RESHADE_DEPTH_INPUT_IS_REVERSED=1
RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #640 by TarekJor
Hellgate London (2007) retail 1.2 => DX9, DX10 modes, x32 and x64 versions each.
Hellgate London: Global / Tokyo (2018 Steam re-release included) => DX9, x32 version only.

Tested, working, ReShade 4.0.2, any .fx I tested.
Install on .exe folders...
DirectX9 (d3d9.dll)
DirectX10 (d3d10.dll)

For D3D9 => d3d9.dll
For D3D10 rename dxgi.dll to d3d10.dll (otherwise game will crash)

Please Log in or Create an account to join the conversation.