Depth Buffer issue in Mass Effect 3: Legendary Edition

More
8 months 4 weeks ago #1 by Exclbr
Hello there,
I recently started playing Mass Effect Legendary Edition and I've used reshade for the first 2 games without issue.With the 3rd game however, I'm having trouble setting up the depth buffer.

I play on 1920x1080 but the list here does not have my resolution.

When i set it to the first one (1920x1440), and turn on Display Depth it looks like this :
The image is stretched to 1920x1440 and the part where the black bar is, is completely blurred when i turn off Display Depth. The other 2 options are the same thing with the black bar only lower resolution as both of them are lower res than the first one. I have anti-aliasing off and I've never had this issue before with reshade. 












 

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago - 1 month 1 week ago #2 by Thamer
Hey man I'm having the same issue and I'm wondering if you found any way to fix it?
This game has so much potential with Reshade I just can't seem to get depth to work properly.

Update: I fixed it!
I added the following the Reshade.ini under the "General" section:

PreprocessorDefinitions=RESHADE_DEPTH_LINEARIZATION_FAR_PLANE=1000.0,RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0,RESHADE_DEPTH_INPUT_IS_REVERSED=0,RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0,RESHADE_DEPTH_INPUT_Y_SCALE=1.333

And in-game you gotta select the 960x720 depth buffer because for some reason it's the only one that works for me
Last edit: 1 month 1 week ago by Thamer.

Please Log in or Create an account to join the conversation.