Reshade infinite loop on old driver

More
1 month 4 weeks ago #1 by bo3bber
Reshade infinite loop on old driver was created by bo3bber
Greetings.  I'm mostly new to Reshade and SuperDepth3D, apologies in advance if this is not the right spot.  I couldn't quite tell how people normally report bugs.  Usually I report bugs via GitHub Issues, which doesn't seem to exist? I'm just going to wing it here, please close this or forward as desired.  Just figured it's worth mentioning.

When running an old Nvidia driver 425.31, when I use the latest version of Reshade 4.9.1 it will hang up in the game in an infinite loop of destroying the environment and rebuilding it.  If no shaders are installed at all, it will start up without error, but any shader that is being compiled will enter an infinite loop.  It seems to be getting a SetFullScreenState which calls ResizeBuffers command from itself, that causes the reset of the environment, and rebuild of any shaders.  I built a clean debug copy of 4.91, and had the same result with no errors noted.

Only happened on 425.31, seems OK on 452.06.  I sometimes need to run the old driver for 3D Vision support.  I was testing the Origin version of Rime.

I realize this is not very interesting because the driver is old, but it's the last fully supported driver for 3D Vision. And I figured it's possible you might want to know about the bug in any case, even if it's not important. As a software developer myself, I like to know about any bugs, in case they might relate to other problems seen.

-bo3b

Please Log in or Create an account to join the conversation.