Welcome, Guest.
Username: Password: Remember me

TOPIC: Final Fantasy XIII 2's depth buffer black screen

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #1

I downloaded the latest ReShade (ReShade 0.19.2 Public Beta with SweetFX 2.0 Beta 8) and used it to display the depth buffer of Final Fantaxy XIII 2. Every time I enabled the depth buffer the screen went black. I have tried other effects (such as SPLITSCREEN) and they worked properly. It seems that the ReShade works properly. According to the list in reshade.me/compatibility, the ReShade can access the depth of this game. What should I do to get the correct depth?
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #2

I have never tried the game so is this only speculation but sometimes antialiasing can interfere with correct depth buffer correction, check that AA is disabled in your driver's settings. It doesn't make any difference with the version of Reshade you are using though, SweetFX does not contain any depth-based shaders.
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #3

  • matsilagi
  • matsilagi's Avatar
  • Offline
  • Posts: 199
  • Thank you received: 54
If it has Multisample Antialiasing (MSAA), it will prevent ReShade from using its depth buffer.

Try disabling it if it has this option.
Loves to test stuff for no reason.
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #4

How can I disable the in-game MSAA?
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #5

  • JBeckman
  • JBeckman's Avatar
  • Offline
  • Posts: 163
  • Thank you received: 36
You have to edit the games config file if I remember correctly, however disabling the MSAA effect causes glitches in-game so it's not recommended.
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #6

I found a custom launcher for Final Fantasy XIII 2 and used it to disable MSAA (i.e. set its level to 0). Afterwards, I rerun ReShade on the game and tried its depth buffer output. The same result (black screen) was observed. Is there anything I am missing in doing so?
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #7

  • Sh1nRa358
  • Sh1nRa358's Avatar
  • Offline
  • Posts: 113
  • Thank you received: 9
If you are using gedosato, it's because gedosato is not compatible with the new update at all and durante won't fix it. If you're not using gedosato, don't use that launch and instead make a shortcut of the exe and use -MSAA=16. One of the reshades still allow DOF to work with MSAA on. 19.0 doesn't because there are errors that come up with with the dof shaders that I guess the creators know (they've never responded to my question about it and I haven't tried 1.0 yet). So try one of the older reshades and maybe that will help.
The administrator has disabled public write access.

Final Fantasy XIII 2's depth buffer black screen 1 year 2 months ago #8

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2452
  • Thank you received: 1391
Sh1nRa358 wrote:
19.0 doesn't because there are errors that come up with with the dof shaders
The ReShade version has nothing to do with the shaders, they are developed separatly (I'm not responsible for those =P ). You could use ReShade 1.0 but with shaders from multiple versions back for instance (the other way does not always work, because ReShade's shading language is constantly improved and thus newer features may be required, but there aren't many reasons to use an old version of the injector).
Cheers, crosire =)
Last Edit: 1 year 2 months ago by crosire.
The administrator has disabled public write access.