[SOLVED] Fallout 4 Syntax error won't compile Reshade

  • Posts: 3
4 years 4 months ago #1 by mjolniir
The message:
F:\Games\SteamApps\common\Fallout 4\/ReShade/GemFX/Bloom.h(540, 21): error X3000: syntax error: unexpected 'integral literal', expected ';'
F:\Games\SteamApps\common\Fallout 4\/ReShade/GemFX/Bloom.h(540, 21): error X3000: syntax error: unexpected 'integral literal', expected '{'

The line referenced is:
RFX_Start_Enabled; int toggle = Bloom_ToggleKey; >

I am not really sure what to make of this yet, I am new to Reshade. This shader is from the default 1.1.0 release and bloom works fine when I just turn it on, the error only occurs when i add a key to toggle bloom on and off. I mostly just want to be able to turn it off and on. The bloom itself isn't bad, but I want to have the option.

Any help would be appreciate since I know only a little on how it works so far,

Please Log in or Create an account to join the conversation.

  • Posts: 3740
4 years 4 months ago #2 by crosire
How did you set the bloom toggle key?

Please Log in or Create an account to join the conversation.

  • Posts: 3
4 years 4 months ago #3 by mjolniir
There is a setting in GemFX.cfg that includes Bloom. Here is the line (105):

#define Bloom_ToggleKey RFX_ToggleKey //[undef] //-Toggle key for Bloom and Bloom dependent shaders.

According to the Reshade\PersonalFiles\KeyCodes.h I added this bit:

#define Bloom_ToggleKey RFX_ToggleKey 107 //[undef] //-Toggle key for Bloom and Bloom dependent shaders.

The added part was the 107 which is the multiply (*) key. When it had the error, I tried several different keys and using hexadecimal as well.

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 3740
4 years 4 months ago #4 by crosire
Should be:
#define Bloom_ToggleKey 107 //...
The key code replaces "RFX_ToggleKey".

Please Log in or Create an account to join the conversation.

  • Posts: 3
4 years 4 months ago #5 by mjolniir
Ahh! Thanks!

Please Log in or Create an account to join the conversation.