Welcome, Guest.
Username: Password: Remember me

TOPIC: Weird keyboard issue with Assassin's creed unity

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #1

  • OtisInf
  • OtisInf's Avatar
  • Offline
  • Posts: 122
  • Thank you received: 51
Hi,

(This happens with reshade v1 and v2 latest). I ran into a weird issue with keyboard input (toggle keys). I copied my v2.02 reshade profile from Assassin's creed syndicate to Assassin's creed Unity install and the toggle keys are too quick: when I press F9, the DoF should be enabled, it is enabled for just a frame, and then disabled again. As if the keyboard buffer isn't cleared... Everything works fine in Syndicate, same reshade, same settings. I also tried with my v1 reshade profile from The Witcher3, same issue: toggle keys are too quick, it's impossible to enable an effect (or disable it).

This might very well be a specific issue with assassin's creed unity, but I'm curious if someone has had this before in another game and / or whether there's a fix for it. Keyboard input in the game is fine, the custom camera mod injected into the game also doesn't have a problem with the keyboard input, so there's something odd going on.

(edit: It's not the camera injected into the game, I run into the same issue if I don't inject that camera)

It's not keyboard repeat, i use the windows defaults. This is on windows 8.1 x64.

Sounds familiar or am I the only one with this weird issue?

Thanks in advance!

(edit) I sometimes can get rid of it when I switch to borderless windowed, but only for a little bit. Downside of using borderless windowed instance is that the depth buffer apparently isn't accessible (empty). Full screen gives access to the depth buffer but enabling an effect is very hard as it's disabled right away again....

Anyway, anyone who has an idea what it might be, let me know :)
Last Edit: 7 months 3 weeks ago by OtisInf.
The administrator has disabled public write access.

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #2

  • JBeckman
  • JBeckman's Avatar
  • Online
  • Posts: 162
  • Thank you received: 36
Unity has been problematic with ReShade but it was a while since I played the game and as such that was with a older version of the injector so some of those issues might have been fixed since, had a lot of problems with the depth buffer detection for example although I did run the game in borderless mode.

Also couldn't get key commands to trigger at all, sounds like that's partially fixed but instead there's some other input issue now.

Perhaps the game is doing something with the input which conflicts with ReShade? I don't really know enough of how that works though.
(Querying keys or something that fills up that buffer you mentioned?)
The administrator has disabled public write access.

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #3

I wonder if it is FPS related.
I do run into problems toggling techniques when FPS is like over 300+ or so, mostly happen in game menu without vsync.
(not AC series, the game called Planet Base if anyone is interested)

@Otis
How did you tell that the DoF is enabled just a frame?
Last Edit: 7 months 3 weeks ago by kingeric1992.
The administrator has disabled public write access.

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #4

  • OtisInf
  • OtisInf's Avatar
  • Offline
  • Posts: 122
  • Thank you received: 51
Thanks JBeckman! Sounds like the probs I have too...
kingeric1992 wrote:
I wonder if it is FPS related.
I do run into problems toggling techniques when FPS is like over 300+ or so, mostly happen in game menu without vsync.
(not AC series, the game called Planet Base if anyone is interested)
I thought about that too, but sadly, it's not. I have Vsync enabled, and as I use a gtx780, fps is below 60. When I enable MSAAx8 things crawl and it still behaves like this. Tried everything, nothing makes a difference, except perhaps borderless windowed, which makes windows perform the sync, but then I don't have access to the depth buffer, making enabling the effects meaningless ;)

Odd thing is that it's the first time I see this.
@Otis
How did you tell that the DoF is enabled just a frame?
Because the scene gets blurred for just a frame, like when you keep the key down, and it flickers on the key repeat. Also my fog shader effect tied to F6 is shown for just a frame: scene is white foggy for a frame, then poof gone. Strange thing is though: you press the key like you would normally, so it doesn't kick in windows key repeat, and the effect is in general enabled->disabled. So it's not repeatedly switched on->off->on->off, even if say, there are 2 frames rendered during the short keypress.

It's a mini-game inside a game ;) When I'm lucky the effect stays enabled when I quickly press the key, but the same hoopla starts again when I want to disable it again: effect is disabled for a frame then enabled again.

I'm not sure how Reshade monitors the keyboard input: is it doing that with a separate thread which pumps WM_KEYDOWN messages, or is it peeking into a buffer of the main process (which might be buggy). But as it works flawlessly in any other game I've run reshade on, it's a blur to me why it happens here (besides it being used in a Ubisoft game, so bugs in the game are a given)
The administrator has disabled public write access.

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #5

I just did a test on Dying Light, same thing happened @60 fps. need to smash my key repeatedly to be able to switch on/off without flipping it back to previous state.
And when the fps drops, it work properly again (in a same scene).

Edit:
upon further test, switching to window mode does make it work under the same frame rate as fullscreen . So I suppose it is not FPS related after all.

Also, another behavior, if holding the toggle key, the effect is going to toggle twice to its original state, then keep the state for a period before starting to flashing on/off.
Last Edit: 7 months 3 weeks ago by kingeric1992.
The administrator has disabled public write access.
The following user(s) said Thank You: OtisInf

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #6

  • OtisInf
  • OtisInf's Avatar
  • Offline
  • Posts: 122
  • Thank you received: 51
kingeric1992 wrote:
I just did a test on Dying Light, same thing happened @60 fps. need to smash my key repeatedly to be able to switch on/off without flipping it back to previous state.
And when the fps drops, it work properly again (in a same scene).
Could indeed be the same I'm seeing when I use borderless windowed: it's slower and it's easier to enable/disable effects in that case. Still odd though that with < 10fps full screen it doesn't... weird issue!

In other games (the witcher 3 (>= 60fps, sync to 30, no prob), ac syndicate, crysis 1 & 2 (60ps)) never had a problem at all, not even once. Wild guess: could be related to how Reshade monitors key input and how the game does that: if the game uses method ABC, reshade has no problem, if the game uses method XYZ, reshade runs into this problem.

Crosire, any ideas? If you want me to run a debug build, let me know. I have vs.net installed, can try to attach a debugger (or even use Cheat engine to debug if you want)) although attaching a vs.net debugger to Assassin's creed executables directly makes the game crash.
Last Edit: 7 months 3 weeks ago by OtisInf.
The administrator has disabled public write access.

Weird keyboard issue with Assassin's creed unity 7 months 3 weeks ago #7

  • OtisInf
  • OtisInf's Avatar
  • Offline
  • Posts: 122
  • Thank you received: 51
*bump* Crosire, any ideas?
The administrator has disabled public write access.

Weird keyboard issue with Assassin's creed unity 7 months 2 weeks ago #8

Hello,

I experience the same behavior in Total War Attila with ReShade 1 and 2.

Some observations I made:
  • after having started the game toggle on/off works without problems for some time
  • most of the time I will be able to toggle on/off if I try to push the Scroll button only for an extremely short period of time
  • the same problem arises when I try to toggle a specific effect, like Tiltshift, which I have bound to another key (e.g. "L")
Usually it's not big a deal as I don't normally toggle the whole ReShade suite on or off. But it would be nice if I could toggle Tiltshift on/off more reliably.

Anyway, keep up the good work!
The administrator has disabled public write access.