Welcome, Guest.
Username: Password: Remember me

TOPIC: ReShade Battlefield 1 can't use keyboard

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #1

  • Bishi
  • Bishi's Avatar
  • Offline
  • Posts: 39
  • Thank you received: 13
Log file here pastebin.com/ywShsrT9
Lots of entries similar to
13/10/2016 14:58:52:208 [10144] | WARN | > 'RegisterRawInputDevices' failed with error code 127!

Also tried with ReShade 1.1.0.963 with same issue.
Origin overlay is disabled (even disabled it app-wide via settings), no other overlays running on PC and all non-essential programs closed

For what its worth, SweetFX 2.0 beta (ReShade 0.15.1.727) DOES work fine.

FYI 3.0.3 fixes this issue.
Last Edit: 1 month 1 week ago by Bishi.
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #2

  • Mbm
  • Mbm's Avatar
  • Offline
  • Posts: 13
Tank you. Got it working.
Now i have to make a preset for this version.
Last Edit: 1 month 2 weeks ago by Mbm.
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #3

  • Mbm
  • Mbm's Avatar
  • Offline
  • Posts: 13
well first it worked. But now it gives my the not responding message when using the shader :(

Okay I found it was FRAPS that caused the problem.. If FRAPS is executed before BF1 it doenst work. But with in BF1 I can tap out and execute FRAPS. Then it works.
And the framerate counter in my user.cfg doesnt work..
So there might be problems with these overlays somehow... more than normal I think.

The shader I use for BF1 can be found here:
sfx.thelazy.net/downloads/
im using the old reshade 0.18
Last Edit: 1 month 2 weeks ago by Mbm.
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #4

obviously also experiencing this issue. Can someone link me to 'SweetFX 2.0 beta (ReShade 0.15.1.727)' so as to try - I cant seem to locate this version anywhere, all links are dead...
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #5

  • Bishi
  • Bishi's Avatar
  • Offline
  • Posts: 39
  • Thank you received: 13
If you just want an FPS counter you can always use "perfoverlay.drawfps 1" in console or user.cfg or you can use shadowplay.
Actually you might even find it in the advanced options in the game menu, they've added a load of things to that.
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #6

  • Mbm
  • Mbm's Avatar
  • Offline
  • Posts: 13
as i wrote perfoverlay.drawfps 1 in user.cfg doesnt work.

this also indicate there are som serious issues with overlays.
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #7

  • Bishi
  • Bishi's Avatar
  • Offline
  • Posts: 39
  • Thank you received: 13
Pretty sure Shadowplay worked for me, so you can try that. Also MSI Afterburner works fine for me here, with SweetFX.
DX11 so YMMV (DX12 slower anyway)
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #8

Tried several versions of reshade and disabled all origin settings, but no Dice;) (no movement possible).
I cann't find SweetFX 2.0 beta ReShade 0.15.1.727 though.
Last Edit: 1 month 2 weeks ago by Skinner.
The administrator has disabled public write access.

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #9

  • TMKlaus
  • TMKlaus's Avatar
  • Offline
  • Posts: 1
  • Thank you received: 1
use this one www.share-online.biz/dl/NQO441FOD5A it works for me. Hurry up, admin is coming.
The administrator has disabled public write access.
The following user(s) said Thank You: Skinner

ReShade Battlefield 1 can't use keyboard 1 month 2 weeks ago #10

Thanks, this one works :)
The administrator has disabled public write access.