[SOLVED] STALKER SoC won't work with latest the version(s)

  • Posts: 177
2 years 10 months ago - 2 years 10 months ago #1 by luluco250
The game works with 3.0.0, but latest versions (including latest from the repo) just don't work.
I don't have other 3.0 versions to test though.

Here's the log:
Warning: Spoiler! [ Click to expand ]


It seems to just randomly uninstall all hooks for no reason.

Edit:
Also ReShade does not seem to detect any key inputs.

Edit 2:
Aaaaand seems to ignore preset configurations.

Please Log in or Create an account to join the conversation.

  • Posts: 2
2 years 10 months ago #2 by Thunderbolt
Same problem here, I've tried just about everything to get it to work and nothing helps, getting the same thing in Max Payne 2 as well.
Maybe it's something to do with the splash screen and ReShade trying to hook into that, then unloading after it disappears?

Please Log in or Create an account to join the conversation.

  • Posts: 18
2 years 10 months ago #3 by Zarathustra
I couldn't get TW-Warhammer to work in Win10 with RS 3.05 and 3.06.
3.04 worked though. You can search in the forum for a link to a repository of older versions.

Please Log in or Create an account to join the conversation.

  • Posts: 2
2 years 10 months ago #4 by Thunderbolt
Found that repo, 3.0.0b4 (or 3.0.0.80) is the last version that works for me in those games.
And by works I mean loads, I can press shift+F2 to bring up the config screen but I can't seem to get it to actually gain focus

Please Log in or Create an account to join the conversation.

  • Posts: 177
2 years 10 months ago #5 by luluco250
I don't know what is up with the Xray engine but for whatever reason renaming ReShade to dxgi.dll worked.
Isn't this game DirectX 9? How does this even happen?

Please Log in or Create an account to join the conversation.