Mount & Blade: Warband 1.172 Won't Launch

More
3 years 6 months ago #1 by Kannibal
Howdy,

I installed ReShade as per the instructions in the guide and my launcher won't run unless I pluck out the d3d9.dll file. Am I doing something wrong?
The following user(s) said Thank You: Nemyss

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #2 by Exilium
Replied by Exilium on topic Mount & Blade: Warband 1.172 Won't Launch
Using the last Windows 10 update?

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #3 by Kannibal
Replied by Kannibal on topic Mount & Blade: Warband 1.172 Won't Launch
Yes, my windows 10 is up to date.

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #4 by Nemyss
Replied by Nemyss on topic Mount & Blade: Warband 1.172 Won't Launch
Same here :Warband won't start. No problems with Witcher 3 though.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago - 3 years 5 months ago #5 by Nemyss
Replied by Nemyss on topic Mount & Blade: Warband 1.172 Won't Launch
There seems to be a problem/conflict with ntdll.dll. Do all DX9 Games have this problem, maybe since a recent W10 Update/Upgrade?

Edit: Dragon Age Origin runs smoothly with reshade DX9. Something wrong with Warband?
Last edit: 3 years 5 months ago by Nemyss. Reason: update

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #6 by Nemyss
Replied by Nemyss on topic Mount & Blade: Warband 1.172 Won't Launch
I checked again. Warband "Viking Conquests" is compatible to DX10 and needs dxgi.dll. then runs ok. Warband "native" won't run neither.
Seems that Warband got some new graphic features. No AO possible though, but thats a M&B problem.
Anyway, thanks to the Reshade Developper. Fantastic tool!

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #7 by fukjap01
Replied by fukjap01 on topic Mount & Blade: Warband 1.172 Won't Launch
Hey guys, I'm having the same issue

The Warband launcher simply won't start at all with the d3d9.dll in the folder, this is really frustrating

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #8 by fukjap01
Replied by fukjap01 on topic Mount & Blade: Warband 1.172 Won't Launch
Anyone able to help out please?

Please Log in or Create an account to join the conversation.