Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade won't work for Sims 4 at all

Reshade won't work for Sims 4 at all 3 months 3 weeks ago #1

I've tried pretty much everything, downloading it for the 64/32 bit version, installing the 3D9, 3D10, OpenGL, i also tried downloading previous versions of it (up til version 3.2.2.) but nothing is working. I pressed all the F2 combos i could think of, but for some reason it just won't show in my game. I do not get a banner on the top of my screen when Sims 4 first loads up either. Does anyone know a way to fix this?
The administrator has disabled public write access.

Reshade won't work for Sims 4 at all 3 months 3 weeks ago #2

Take a look at this checklist (some of the bullet points apply to older versions, like unzipping since you don't need to now): pictureamoebae.tumblr.com/post/148884043...hade-troubleshooting

Make sure you've checked all of those things. I'll outline some below.

First of all, you're on PC and not Mac, right? ReShade doesn't work on a Mac.

If you don't get the banner at the top when you open the game it means ReShade isn't hooking into the game for some reason. Usually it's an installation error on the part of the user, but now that almost all of the process is automated I would expect those instances to be rarer. Just to check though, go into your Bin folder (where your ts4 exe is) and check that you have these files (for the most recent ReShade versions):
  1. reshade-shaders (folder)
  2. d3d9.dll

If those are directly in the Bin folder then you have theoretically installed it correctly.

The next thing to do is change the name of d3d9.dll to see if you can get it to hook in. Try d3d11.dll or dxgi.dll. If neither work, change it back to d3d9.dll (because that's what it should be in most cases).

Try runnng Origin and TS4 as admin.

Make sure you have this directx runtime installed on your computer: www.microsoft.com/en-us/download/details.aspx?id=8109
The administrator has disabled public write access.