DOF shaders don't work well in Quake 2

More
1 year 11 months ago #1 by Omeganinjaboy
DOF shaders don't work well in Quake 2 was created by Omeganinjaboy
All of the DOF shaders either detect the whole screen as the background (farther away) or only detects things 5 feet from my face as the foreground half the time. Is it just Quake 2 being an old game? Did I do something wrong?

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago - 1 year 11 months ago #2 by Daodan
Replied by Daodan on topic DOF shaders don't work well in Quake 2
In the ReShade compatibility list Quake 2 has a 'perfect' rating so I guess that should work.
DOF shaders rely on the depth buffer, so first enable the DisplayDepth shader to see if that works correctly: you should see a greyscale image with near objects in black and far away objects in white.
If you see only black or white, try changing the values for the depth buffer input (in the settings tab from the ReShade UI):
RESHADE_DEPTH_LINEARIZATION_FAR_PLANE=1000.0
RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0
RESHADE_DEPTH_INPUT_IS_REVERSED=0
RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0
Set RESHADE_DEPTH_INPUT_IS_REVERSED to 1 or 0 and/or RESHADE_DEPTH_INPUT_IS_LOGARITHMIC to 1 or 0.
After you change a value reload the shaders.
Last edit: 1 year 11 months ago by Daodan.
The following user(s) said Thank You: Omeganinjaboy

Please Log in or Create an account to join the conversation.