Reshade keys don't work when pressed together with modifier keys

  • Posts: 285
3 months 3 weeks ago #1 by brussell
I've noticed that with recent ReShade versions the keys (Screenshot, Toggle Effects etc.) don't work when pressed together with Alt, Ctrl and Shift.
Is this intentional or a bug?
It's main nuisance for me is is the impossibility for taking screenshots in games while using these keys, e.g. when running (Shift), looking around (Alt), or crouching (Ctrl).

Please Log in or Create an account to join the conversation.

  • Posts: 3749
3 months 3 weeks ago #2 by crosire
That is intentional. Since you can bind different actions to key + modifier combinations.

Please Log in or Create an account to join the conversation.

  • Posts: 285
3 months 3 weeks ago #3 by brussell
Ok. But why does this worked well for ReShade 3, where you can also set keys with modifier? Why disable the key, when you don't actually use a modifier?

Please Log in or Create an account to join the conversation.

  • Posts: 285
3 months 3 weeks ago #4 by brussell
Was this introduced with this commit?:
github.com/crosire/reshade/commit/811ebf...6ca93e35941438788c8f

Then what did it fix? If it's nothing serious I would strongly prefer the old behavior.

Please Log in or Create an account to join the conversation.

  • Posts: 3749
3 months 3 weeks ago - 3 months 3 weeks ago #5 by crosire
It is that commit. Say you have two shortcuts set: "Space" and "Shift + Space". Pressing Shift and Space would previously activate both shortcuts, when really it should only activate the latter.
This was especially annoying if you had set multiple effect toggles to shortcuts with different modifiers.
The following user(s) said Thank You: brussell

Please Log in or Create an account to join the conversation.

  • Posts: 285
3 months 3 weeks ago - 3 months 3 weeks ago #6 by brussell
Ok. So there is either the problem with multiple shortcuts with different modifiers for the same key not working together (old way), or the problem with not usable shortcuts when pressed together with modifier keys, even if they aren't used (new way).

Could there be a middleground, like allow the multipliers for a shortcut, if they are not used for another one?
So Shift+Space would work fine for a "Space"-only Shortcut, as long as there is no other shortcut defined with "Shift+Space".

Would this be much hassle to implement?

Please Log in or Create an account to join the conversation.

  • Posts: 3749
3 months 3 weeks ago - 3 months 3 weeks ago #7 by crosire
It would be nice. But it's not really feasibly from both a performance and implementation perspective to search for and check every other shortcut every time one is pressed, just to decide on behavior.

Please Log in or Create an account to join the conversation.

  • Posts: 285
3 months 3 weeks ago #8 by brussell
Yeah, I understand the objection.

But (:)), I see one last, less ugly solution: Making the two methods switchable via ReShade.ini setting, like:
[INPUT]
InputModifierBehavior=2 
...
It doesn't necessarily have to be visible in the GUI, and standard behavior would be the current one.

What do you think?

Please Log in or Create an account to join the conversation.

  • Posts: 3749
3 months 3 weeks ago #9 by crosire
Added in github.com/crosire/reshade/commit/32613f...635b3447c6a298345654 .

Use the following to regain old behavior:
[INPUT]
ForceShortcutModifiers=0
The following user(s) said Thank You: brussell

Please Log in or Create an account to join the conversation.

  • Posts: 285
3 months 3 weeks ago - 3 months 3 weeks ago #10 by brussell
Awesome, thank you very much! :cheer:

Please Log in or Create an account to join the conversation.