Help! Can't get reshade to work in assetto corsa

  • Posts: 1
3 months 2 weeks ago #1 by TonyAr
So I've tried just about everything i could find on google to no success so i thought i would ask for help on here. I went through the normal installation which of reshade but when in game i cannot get the reshade menu to show. I tried shift+F2, shift+F10, home and just about every other button combination i could think of. I even added the input lines in the reshade .ini file but still nothing. Went through about 10 installs/uninstalls. I then tried manually installing the .dll which still didnt work. Any help would be very much aprecieated.

Tony.

Please Log in or Create an account to join the conversation.

  • Posts: 176
3 months 2 weeks ago - 3 months 2 weeks ago #2 by brazzjazz
When ReShade is loaded, you should at least get a message in the top-left corner, prompting you to press a certain button (it will then say Pos1 per default). Do you get that message? Because if you don't, then ReShade is not even loaded. If it is a multiplayer game you're playing, then maybe that is the reason, because in that case ReShade does not get loaded as a precaution against anti-cheat measures. If that is not the case: did you choose Direct3D 10-12 as the API? The game seems to use Direct3D 11. That should get you a dxgi.dll. Next thing: do you have a dxgi.log? That should tell you whether ReShade was actually loaded or not.

Please Log in or Create an account to join the conversation.

  • Posts: 455
3 months 2 weeks ago #3 by Martigen

brazzjazz wrote: If it is a multiplayer game you're playing, then maybe that is the reason, because in that case ReShade does not get loaded as a precaution against anti-cheat measures.

What? No :) Only the depth buffer access is disabled for online games, which is only used by a handful of shaders (mainly MXAO). Otherwise all shaders can be used just fine in multiplayer games.

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 months 2 weeks ago #4 by SloMoHAcker
I have had the same problem as you, my friend.
I have fixed it by renaming dxgi.dll to d3d11.dll.
I hope this fixes it for you too.

Please Log in or Create an account to join the conversation.