Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] ARMA 3 doesn't launch

[ARMA 3] Game doesn't launch 2 years 3 months ago #1

  • Tike
  • Tike's Avatar
  • Offline
  • Posts: 2
Whenever I install ReShade and I try to launch the game nothing happens. However the process appears at ~10 MB in the task manager. Tried changing the malloc and the way I launch with no luck. What could cause this?
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2749
  • Thank you received: 1570
Another overlay conflicting with ReShade for instance. Check if any other tool hooking into D3D is running =).
Cheers, crosire =)
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #3

  • Tike
  • Tike's Avatar
  • Offline
  • Posts: 2
Could Steam Overlay break things?
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2749
  • Thank you received: 1570
Nope, Steam is compatible.
How did you call the ReShade DLL?
Cheers, crosire =)
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #5

Unfortunately I got the exactly same error. Game will crash on startup.
Last Edit: 2 years 3 months ago by nikiforos.
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #6

Hello, I frequently play around with ReShade in Arma 3 so maybe I can help.

Bohemia doesn't really have good anti-cheat(honestly they don't know how to do it right at all) and they could of possibly; in the latest update broke using ReShade with their game launcher. (this is just speculation, I never use the default methods to launch arma titles since arma 2, mod list control is easier with launchers from the community.)

I personally use this launcher from Armaholic that some guy made, I like it better for the mod-list control.

www.armaholic.com/page.php?id=24546

If it's not that make sure your .Dll is called dxgi.dll
That's what it should be (or at least what it's always been for me)

Make sure no other overlays are up, Fps counters and the like and etc.
Steam overlay does work. I use it all the time.

Hopefully you figure it out, Arma 3 really needs ReShade. The stock visuals are absolutely terrible.
I'm always learning.
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #7

This is what I get checking after fail startup:

11/05/2015 19:41:30:974 [04736] | WARN | > 'IDXGIFactory::CreateSwapChain' failed with 'DXGI_ERROR_INVALID_CALL'!

Constantine PC wrote:

If it's not that make sure your .Dll is called dxgi.dll
That's what it should be (or at least what it's always been for me)

What do u mean? After the Reshade installation I got one dxgi.DLL in the Arma 3 root directory. Does it matter if it capital letters or not?

Thank you for your help! :)
Last Edit: 2 years 3 months ago by nikiforos.
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #8

I am also having trouble. I've updated directx, and I don't think that I have messed up while installing it reshade and sweetfx. I'm getting an exit code of 0xC0000005 after immediately crashing to desktop if that helps at all. I'd really like to get this working, I know many others are having this same problem with arma 3. I got the exact same error message in my dxgi.log file as nikiforos did
Last Edit: 2 years 3 months ago by steeze.
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #9

Nice to know I'm not alone steeze :)

I tried everything to be honest but with no success :(
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #10

Really wish I could help. As I said earlier I use a launcher that doesn't start up the Battle-eye process so it might be conflicting, I don't know. I'd rather not try it though in case Bohemia has blocked injectors (as they did in DayZ).

All I have in my Arma 3 folder is:
ReShade Folder
dxgi.dll
ReShade.FX

I have a preset here that contains working files (at least for me, anyways)
I'm on windows 7 64bit

preset: www.dropbox.com/s/sqexxtomapo4kc3/Arma%2...listic%20V2.zip?dl=0

(maybe it can help you with installation and the proper files. I don't know, I think you guys are installing it right)

make sure you guys are using a more recent Reshade.dll - I used to have crashing issues on start up with older ones (much older ones it was fixed a while ago)

Oh also software that forces triple buffering can cause issues too like d3doverrider (or whatever its called)

I'm only bringing up battle-eye as a possible culprit because about a update ago I saw: "Battle-eye has been moved to it's own process"
And knowing Bohemia that never means anything good.
I'm always learning.
Last Edit: 2 years 3 months ago by Constantine PC.
The administrator has disabled public write access.
The following user(s) said Thank You: steeze

[ARMA 3] Game doesn't launch 2 years 3 months ago #11

Thank you for the reply Constantine PC. I have tried the separate launcher you mentioned, but it just started the official Arma 3 launcher. I will try the preset you have because I also have windows 7 64 bit. It doesn't make sense though that some can get it to work and others can't, I know that it is not just us that are having issues, many others are as well.

Edit: I installed the files you uploaded...It didn't work! :( I just don't get it, we have the same operating system. I'm about to do a clean install but I doubt that would even work
Last Edit: 2 years 3 months ago by steeze.
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #12

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2749
  • Thank you received: 1570
Make sure you have the Windows 7 platform update installed.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: steeze

[ARMA 3] Game doesn't launch 2 years 3 months ago #13

No way, I will never install this since I read a lot of issues and BSODs using that.
I have to accept no Reshade for me!
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #14

It works! I even thought that the windows service pack version was the only variable left in the equation...but I hate windows so much I had never downloaded a single update ever on this particular windows 7. Anyway, I downloaded both the service pack, and then that specific update that you linked, and reshade works without any problems! Thank you so much, arma definitely looks good!
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #15

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2749
  • Thank you received: 1570
Glad to hear! =)

And @steeze: That's not a very good idea. These updates are there for a reason and that reason is not to annoy customers, but to fix dangerous security vulnerabilities and add features developers are using in there applications (and you'll run into more issues sooner or later).
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: steeze

[ARMA 3] Game doesn't launch 2 years 3 months ago #16

steeze wrote:
It works! I even thought that the windows service pack version was the only variable left in the equation...but I hate windows so much I had never downloaded a single update ever on this particular windows 7. Anyway, I downloaded both the service pack, and then that specific update that you linked, and reshade works without any problems! Thank you so much, arma definitely looks good!

Can i ask you which preset are you using ? I read everywhere that the preset of Constantine PC is amazing, but i dont know which one is best for performance/quality wise of the colors for reality... The FrameWork or the MER one ? I have tried the Arma 3 Enhanced - 1.5.1 FINAL one but it looks too cartoonish for me... Thanks for your help guys! :)
Last Edit: 2 years 3 months ago by DaWiLd.
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #17

Use whatever one you like honestly. If that means it's the 1.5.1 one it's the 1.5.1 one.

I change presets for that game like every day. I'm pretty much always playing around with the settings for something.

Beauty of ReShade/shaders is you can make the game look the way you want personally. You can just use one of mine or someone elses as a template and add more saturation, contrast etc.

That's what I recommend doing.
I'm always learning.
The administrator has disabled public write access.
The following user(s) said Thank You: DaWiLd

[ARMA 3] Game doesn't launch 2 years 3 months ago #18

Constantine PC wrote:
Use whatever one you like honestly. If that means it's the 1.5.1 one it's the 1.5.1 one.

I change presets for that game like every day. I'm pretty much always playing around with the settings for something.

Beauty of ReShade/shaders is you can make the game look the way you want personally. You can just use one of mine or someone elses as a template and add more saturation, contrast etc.

That's what I recommend doing.

Is there a huge difference between your 2 preset ? I mean one is MER and the other one is FrameWork ? Is there a huge difference ? Sorry for these questions im pretty noob in this reshading universe:P
The administrator has disabled public write access.

[ARMA 3] Game doesn't launch 2 years 3 months ago #19

Yes there is a huge difference.

Use any preset on the database you want and tweak from there. Think of it like a template for you to improve rather than a static modification.
People have different tastes and etc.
I'm always learning.
The administrator has disabled public write access.