Frustration with Dxgi.dll and dup. .dll's

More
6 months 3 weeks ago - 6 months 3 weeks ago #1 by Gotthemshaders
Frustration with Dxgi.dll and dup. .dll's was created by Gotthemshaders
Few months back, Reshade stopped working. Was told to rename dxgi.dll to d3d11.dll.
Okay great reshade works again . In comes the conflict : I found a program that I REALLY want to use WITH Reshade : ( 3dmigoto).
( 3dmigoto works well in game , no issues . Problem is > it also uses a d3d11.dll.

Some one who does not have the dxgi.dll issue I have, confirmed for me, Both Reshade using dxgi.dll and 3dmigoto ;d3d11.dll
work well together with the latest Reshade and StarCitizen . ( without any fancy setup .Just drag and drop ) .
Proof : ( DarkStarSwords' Image of his Star Citizen set up using both programs at once . )


(He helped me troubleshoot the Loader for 3dmigoto so that reshade could use the d3d11.dll .
That did not work after many hours of trying . I've tired injectors and wrappers to no avail too .)

Short of a system wipe, I REALLY want help to find why my system is not using dxgi.dll anymore .
Mainly, How do I fix it ? As pictured .
Last edit: 6 months 3 weeks ago by Gotthemshaders. Reason: cleaned up typos and redundancy .

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #2 by Gotthemshaders
Replied by Gotthemshaders on topic Frustration with Dxgi.dll and dup. .dll's
bump. anyone ?

Please Log in or Create an account to join the conversation.

More
6 months 1 day ago #3 by motosxorpio
Replied by motosxorpio on topic Frustration with Dxgi.dll and dup. .dll's
Have you tried this: github.com/bo3b/3Dmigoto/releases

This loader can be used if dxgi is required earlier than d3d11, like ShadowOfWar. Works for both Win7 and Win10, but is x64 only. This is not the same as the 3DMigoto Loader.exe shipped with 3DMigoto 1.3.15+ and is used in different circumstances.

x64 dxgi.dll loader <--link, on that page

Please Log in or Create an account to join the conversation.