Welcome, Guest.
Username: Password: Remember me

TOPIC: Low performance in Gtx 1070ti

Low performance in Gtx 1070ti 3 months 3 weeks ago #1

My God in heaven, I'm working on a remake of NFSU2 and would use Reshade framework to put some effects like deph of field and ambient occlusion , but the second more powerful graphics card market can not bear run ! What is it? Who is playing my remake will need 10 gtx 1080 you to play ? And this compilation message, will never take it not ? Everyone knows who the creators because the names are in all files , no one likes this annoying message digest !
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #2

  • TreyM
  • TreyM's Avatar
  • Offline
  • Posts: 28
  • Thank you received: 7
WTF?
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #3

I am outraged! I'll need $ 100,000 of equipment to be able to run the Reshade Framework in a beautiful quality!
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #4

  • ShoterXX
  • ShoterXX's Avatar
  • Offline
  • Posts: 53
  • Thank you received: 9
A: 1070ti... What?
B: I have a 1070, playing U2, running SSAO, DOF, Gaussian, all at full resolution and my own code on top, and it's 60 FPS always (V-Sync). Depending on the ambient temperature, it's not even enough to turn the fans on (because my card allows it when load is low). If it's doing poorly, either something is misconfigured and not taking full advantage of your card, or you are clearly abusing on the effects you're adding.
C: Why does it bother so much to see that text?
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #5

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 609
  • Thank you received: 719
I have a GTX 970 and there is no shader for ReShade that could drop the fps below 60 (if I don't intentionally use some "kill pc configuration" though). Could you please provide some information about what configuration/shaders you use? Because any good video card should run virtually any Framework config 60fps+ so there must be something out of the ordinary.

Creators messages won't be removed because no users looks into the files and there are already too many people claiming our work for their own. Nothing to discuss or negotiate about that.
Last Edit: 3 months 3 weeks ago by Marty McFly.
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #6

Activated effects:

Ambient Light
Bloom
Dirt Lens (Custom PNG)
Delph Of Field (Quality 10)
Ambient Occlusion (HBAO)
Levels
Lumasharpness
SMAA

The game is running at 29 fps on a graphics card with 8GB of memory!
The problem seems to be in HBAO when it is activated the game has a drastic drop fps!
Last Edit: 3 months 3 weeks ago by Exilium.
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #7

Here you can see some screenshots: www.dropbox.com/sh/kk405m3dc7az6sn/AAApX...obZRirRgC3--bsa?dl=0
Some effects are not captured ...
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #8

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 609
  • Thank you received: 719
HBAO is shit and kills your fps, that's right. It's just there for compatibility reasons. Use any other AO shader like Crysis AO, that one runs very well.
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #9

  • ShoterXX
  • ShoterXX's Avatar
  • Offline
  • Posts: 53
  • Thank you received: 9
To be honest, that shouldn't be that big of a deal. I believe it might be something else.
Though, yeah, there are better ones.
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 3 weeks ago #10

Thank you guys a better idea to remove compilation text would put an intro with the name you as the effects are compiled =D it would be beautiful too. Marty, it would be possible to use MXAO with Reshade Framework?
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 2 weeks ago #11

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 609
  • Thank you received: 719
I refused to do so for ages but I see that many people want it so yeah, here's how to add MXAO to the Framework. Since the structure of MXAO differs from the old methods I used in the SSAO that's in the Framework already, I'd have to overthrow every existing config by adapting it so here's how to add MXAO as separate effect (some things like AO fade out are redundant with those in SSAO.fx but ignore that, you won't be using MXAO and other SSAO together :p):



1) Add this to Shaders_by_MartyMcFly.cfg:

Warning: Spoiler! [ Click to expand ]


2) Create new file called "MXAO.fx" in ReShade\Shaders\MartyMcFly and put that into it:
pastebin.com/Mm5JqR0x

3) Add this to the top of ReShade\Shaders\MartyMcFly.undef:

Warning: Spoiler! [ Click to expand ]


4) Finally, drop "#include EFFECT(MartyMcFly, MXAO)" somewhere in the Pipeline.cfg for your preset, preferably at the very start because AO has to run early in a render pipeline to not fuck up DoF or bloom or like anything else.

I tested that with the NaturalVision preset by user Razed and it seems to work just fine.
Last Edit: 3 months 2 weeks ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: acknowledge, Kuniyo, Ryukou36, Exilium

Low performance in Gtx 1070ti 3 months 2 weeks ago #12

  • klotim
  • klotim's Avatar
  • Offline
  • Posts: 66
  • Thank you received: 21
" Who is playing my remake will need 10 gtx 1080 you to play"

I love google translate
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 2 weeks ago #13

I will test, ty for share...
The administrator has disabled public write access.

Low performance in Gtx 1070ti 3 months 2 weeks ago #14

It worked perfectly if you want to take a look at my website, has the credits for you and the other creators of Reshade not put all, only the effects of creators who are activated, for example: deph of field (you) - levels ( ceejay.dk) etc ...

Here the link if you want to check
bernardjakemello.wixsite.com/underground2016
The administrator has disabled public write access.

Low performance in Gtx 1070ti 2 months 1 week ago #15

Hey Marty, I found something strange in the Reshade framework(I used the lastest 2.0.3.1120 version) port of your wonderful MXAO shader. Below are some comparison pics:

1. without any effect:



2. MXAO only:



3. MXAO with debug view enabled:



As you can see, MXAO creats some contour around the characters, which will not be found using your previous SSAO shaders in framework and Master_effect .

I've also test several other games, and MXAO generated contour most of the time , very annoying.

Also there is a string Unalbe to load source for texture 'texdither'! in the upper left corner each time MXAO was switched on/off.

Any workaround you can do on these problems?T hanks in advance!
The administrator has disabled public write access.

Low performance in Gtx 1070ti 2 months 1 week ago #16

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2451
  • Thank you received: 1390
Now that's an easy one. You are missing the dither pattern texture MXAO requires to dither the results and get rid of those artifacts. It's part of the official MXAO download somewhere on this site.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: acknowledge

Low performance in Gtx 1070ti 2 months 1 week ago #17

crosire wrote:
Now that's an easy one. You are missing the dither pattern texture MXAO requires to dither the results and get rid of those artifacts. It's part of the official MXAO download somewhere on this site.

Finally it's fully operational, thanks for your tip!
The administrator has disabled public write access.