Welcome, Guest.
Username: Password: Remember me

TOPIC: temporarily disable reshade

temporarily disable reshade 2 months 3 days ago #1

  • Camiel
  • Camiel's Avatar
  • Offline
  • Posts: 12
  • Thank you received: 1
I've noticed that Reshade 3.0 still enumerates all effects regardless their toggle state
so that even if they are all disabled, still pops up from time to time and re-enumerates everything
causing the game to freeze for quite awhile.
I wonder if there is toggle disable/enable for the process itself
The administrator has disabled public write access.

temporarily disable reshade 2 months 2 days ago #2

  • Golgotha
  • Golgotha's Avatar
  • Offline
  • Posts: 20
  • Thank you received: 8
Have you enabled performance mode in the settings? In the beginning it took me a while to realize I was still in configuration mode. This will speed up compilation time, not to mention FPS in general.

Beyond that the only thing you can really do is delete unused shaders from the shaders folder to keep them from compiling.
Camiel wrote:
still pops up from time to time and re-enumerates everything
causing the game to freeze for quite awhile.

However, that should not be happening unless you're alt-tabbing or changing resolutions or something and that seems to be your gound-zero for annoying. That only happens to me when I push my video card overclock too hard and/or is overheating and the video driver starts hanging, but restarts without crashing, which would be accompanied by a reshade recompilation.

My suggestion would be to ease up on your overclock if you are and/or (don't you love and/or? so different from either/or! Do any languages have commonly used differentiations of or? I believe this flaw in our reality-mapping software is perhaps our most efficient vector of stupid, providing a climate favorable to angry orange folk. Without and/or, your idea must displace mine; therefore murder Just ignore this) set your fan to a higher setting and clean dust of its heatsink. Using something like MSI Afterburner could help give you an idea whats going on when this occurs. I'd bet you'd see a temperature spike before this happens.
The administrator has disabled public write access.
The following user(s) said Thank You: crosire

temporarily disable reshade 2 months 2 days ago #3

  • Camiel
  • Camiel's Avatar
  • Offline
  • Posts: 12
  • Thank you received: 1
Thank you for the thorough reply
I don't overclock or have any temperature problems
I did delete/rename unused effects and switch resahde to performance mode.
Those were the first things i did and although i only use 1 or 2 light effects like Vibrance and deband,
the problem still remains.

Maybe it has something to do being an online game ? (gw2)
Cause most often happens on map change, loading screens, populated areas with lag spikes -again, on loading data.

(and then the soul grows older, becomes battle weary and upon letting go of and/or forgetting
languages-reality mappings, because It now knows it doesn't go anywhere,
lives... and leaves oranges live too)
The administrator has disabled public write access.

temporarily disable reshade 2 months 22 hours ago #4

  • baal80spam
  • baal80spam's Avatar
  • Offline
  • Posts: 3
  • Thank you received: 1
I experience the same behaviour with Guild Wars - teleporting to an outpost or entering / exiting one always triggers the shader recompilation. It was exactly the same with ReShade 2.x. I guess the game engine handles graphics in such a way.
The administrator has disabled public write access.

temporarily disable reshade 1 month 3 weeks ago #5

  • Camiel
  • Camiel's Avatar
  • Offline
  • Posts: 12
  • Thank you received: 1
found out that using the -32 switch on the x64 gw2 client executable alleviates the problem quite substantially
so the shortcut should be looking something like:
Gw2-64.exe -32
it supposedly forces the client to run in 32bit mode
didn't have the time to test it extensively tho
The administrator has disabled public write access.

temporarily disable reshade 1 month 3 weeks ago #6

  • Camiel
  • Camiel's Avatar
  • Offline
  • Posts: 12
  • Thank you received: 1
Update: It's the "windowed fullscreen" that causes the problem.
in normal fulscreen mode reshade enumerates only after loading game screens

Just in case anyone stumbles upon the same issue
The administrator has disabled public write access.
The following user(s) said Thank You: euphorio

temporarily disable reshade 1 month 3 weeks ago #7

  • moriz1
  • moriz1's Avatar
  • Offline
  • Posts: 22
  • Thank you received: 16
you can also move shaders that you aren't using, out of the shaders folder. this won't prevent the recompile on every loading screen, but would drastically shorten the recompile so that it is almost unnoticeable.
The administrator has disabled public write access.
The following user(s) said Thank You: euphorio