Welcome, Guest.
Username: Password: Remember me

TOPIC: Change keybinding in reshade 3.0.X ?

Change keybinding in reshade 3.0.X ? 2 years 11 months ago #1

I need to change the key to open the in-game menu. How?
Last Edit: 2 years 11 months ago by alike.
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 years 11 months ago #2

Go to the "Settings" tab. First option there lets you change the key.
Cheers, crosire =)
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 years 11 months ago #3

Forgot to say that I can't open the setting menu because when I press my F keys, it pops out into Windows and opens something there. It's because I'm on a bad keyboard that has these function keys all over it and it uses the F keys for them...
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 years 11 months ago #4

That means that you have to press the function key as well.
Because if say F2 has also screen brightness as function, it's either that a normal key press triggers F2 and key press plus function key gives you screen brightness control - or vice versa.
Seems like the latter is the case for you so to actually access the F2 key you need to press the function key as well. Just pressing the key actually doesn't mean pressing F2.
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 years 11 months ago #5



This is the keyboard I have. It's not a notebook computer :)

Is there a file I can edit to change the key?
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 years 11 months ago #6

d3d9/dxgi/opengl32.ini > KeyMenu

First number is the key code (www.mods.com.au/budapi_docs/Virtual%20Key%20Codes.htm), second is whether to use ctrl, third is whether to use shift.
Cheers, crosire =)
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 years 3 months ago #7

crosire wrote:
d3d9/dxgi/opengl32.ini > KeyMenu

First number is the key code (www.mods.com.au/budapi_docs/Virtual%20Key%20Codes.htm), second is whether to use ctrl, third is whether to use shift.

I know this thread is old but I'm currently having the same issue.
I'm on a keyboard and I do pressed FN and F2, it brings up nothing.

I tried to follow the directions but I don't know what you mean by
d3d9/dxgi/opengl32.ini > KeyMenu where am I supposed to find that?
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 1 year 6 months ago #8

How do you do that? It doesn't explain anything
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 6 months 3 weeks ago #9

I also had to solve this issue myself, with very little helpful input from anyone else. I hope this explanations offers some help to others who encounter this issue as well:

The default input to bring up the KeyMenu (i.e. the UI for ReShade) in-game is supposedly SHIFT + F2, but that certainly was NOT the case for me. If you're having this issue, you might think your keyboard is to blame if you, like me, have a keyboard whose dedicated function keys aren't actually enabled without pressing the function button (usually labeled FN on your keyboard).

Crosire suggested checking the .INI file for ReShade to see what key codes were in place to bring up the KeyMenu, but their suggestions for the file name (d3d9, dxgi, or opengl32) were once again, supposedly the default .INI file with which to check this information, but once again, that certainly was NOT the case for me.

Instead, the .INI file for ReShade was installed in my game's installation folder (in my case, the steam common folder for Fallout: New Vegas), and was labeled as RESHADE.INI. Crosire was correct in their suggestion to look up what the virtual key codes were, and when I did, I saw in the sixth line of the RESHADE.INI file that the input for bringing up the KeyMenu was 36,0,0,0. In other words, the Home key. As I said, I have a keyboard with a dedicated function button, so in my case, I needed to hold down my FN key while pressing the left arrow key, which inputs the Home button function on my keyboard. Once I did, I saw the KeyMenu pop up as it had when first installed, and I was able to make all the changes I wanted.
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 6 months 3 weeks ago #10

Well yeah, this information herewas for ReShade 3 (see title). Things changed in ReShade 4 as you noticed.
Cheers, crosire =)
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 months 2 weeks ago #11

crosire wrote:
Well yeah, this information herewas for ReShade 3 (see title). Things changed in ReShade 4 as you noticed.

Hey crosire,

Sorry to bump this old post but I'm running into the same issue now. Additionally, my FN key doesn't seem to work which means I have no whatsoever way to access the in-game menu. Is there any way to change the keybinding via the .INI file?

Thank you in advance.
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 months 2 weeks ago #12

Yes. In ReShade.ini, as explained above.
Cheers, crosire =)
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 months 2 weeks ago #13

crosire wrote:
Yes. In ReShade.ini, as explained above.

Thanks. What line should I put in the .ini, though? My .ini doesn't have the input line.
The administrator has disabled public write access.

Change keybinding in reshade 3.0.X ? 2 months 2 weeks ago #14

If it is not there, just add it. E.g.
[INPUT]
KeyMenu=40,0,0
Cheers, crosire =)
The administrator has disabled public write access.