Gothic 3: fps tanks with Reshade(or with Sweetfx)

More
4 years 4 months ago #1 by Amador Gothic 3: fps tanks with Reshade(or with Sweetfx) was created by Amador
I just don't get what's up with this game, it runs 60+ fps smooth but any version of reshade/sweetfx reduces the fps to a choppy 15-20. I have the GOG version fully patched to CF 1.75. I've tried dozens of things to fix it, but I just can't , which is really a shame as reshade would really help this old RPG.

Anyone have an idea or a solution? When I read through the internet it seems most people can run reshade fine with Gothic 3, I have a Radeon RX 570, could that be the problem?

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #2 by lowenz Replied by lowenz on topic Gothic 3: fps tanks with Reshade(or with Sweetfx)
Try disabling the VSync.

For me G3+Unofficial Patch+Some other patches (maxed out quality but NO postprocessing) 100 FPS -> 70 FPS with reshade (no effects)

i3-6300 + GTX 1050 Ti
Last edit: 4 years 4 months ago by lowenz.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #3 by Amador Replied by Amador on topic Gothic 3: fps tanks with Reshade(or with Sweetfx)
Sadly that didn't fix it. I too get 100fps or even bigger, but reshade pulls it down to 15-30.. And I only tried sharpening and curves yet..

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #4 by lowenz Replied by lowenz on topic Gothic 3: fps tanks with Reshade(or with Sweetfx)
Maybe it's something in the Gothic 3 postprocessing options.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #5 by thalixte Replied by thalixte on topic Gothic 3: fps tanks with Reshade(or with Sweetfx)
In the reshade UI there is a stats tab that can provide to you some usefull infos about the CPU and GPU frametime. Maybe you could look at it...
Last edit: 4 years 4 months ago by thalixte.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #6 by Amador Replied by Amador on topic Gothic 3: fps tanks with Reshade(or with Sweetfx)
Yep, it's probably the modern AMD videocard (RX 570) the game doesn't like, just upgraded the display driver and now it's even worse, enabling shift + f2 often crashes the game, loading savegames results in a black screen while I can still hear everything. Rebuild shaders for Gothic 3 but that didn't fix it. I remember running Sweetfx just fine with other video cards just a few years ago.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #7 by Sinclair Replied by Sinclair on topic Gothic 3: fps tanks with Reshade(or with Sweetfx)
So no solution was ever found for this? I just built out a patched instance of Gothic 3 on my Win 10 system, and I experienced exactly what Amador described (runs fine without Reshade, but drops to ~10 fps with). It must be some issue with how the Reshade .dll interacts with Gothic's built-in post processing. But even if I turn off all of Gothic's internal effects, it's the same.

Wish there were a way to get them to play together nicely, as the game could definitely stand some Reshade lovin'

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.