Welcome, Guest.
Username: Password: Remember me

TOPIC: About the blend of effect

About the blend of effect 10 months 3 weeks ago #1

Why is different the effect whether displaying or not of ReShade GUI?
#include "ReShade.fxh"

float4 TestPass(
	float4 pos : SV_Position,
	float2 texcoord : TEXCOORD
) : SV_Target
{
	return float4(
		0.0,
		step(pos.x % 64,32),
		step((BUFFER_HEIGHT - pos.y) % 64,32),
		0.0);
}

technique Test
{
	pass
	{
		VertexShader = PostProcessVS;
		PixelShader = TestPass;
		
		ClearRenderTargets = false;
		BlendEnable = true;

		DestBlend = ONE;
	}
}
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #2

There isn't?
Cheers, crosire =)
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #3

I tried again now, I noticed this problem is causing only by d3d11.
And do not put enabled technique after the Test.
Last Edit: 10 months 2 weeks ago by seri14.
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #4

Still cannot reproduce this =/
Cheers, crosire =)
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #5

Recorded.
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #6

Just tested it and I also see a difference whether the ReShade overlay is shown or not.
I used the Release App and the Snipping Tool to take the screenshots.
(The 'DrawOverlay' technique is just a shader to draw an image onto the screen)





One thing to note: when a screenshot is taken from within ReShade the result looks like in the first image - it doesn't matter if the overlay is enabled or not.
Last Edit: 10 months 2 weeks ago by Daodan.
The administrator has disabled public write access.
The following user(s) said Thank You: seri14

About the blend of effect 10 months 2 weeks ago #7

Are you both on Windows 10? I have never been able to reproduce any of the "things look different with UI on/off" bugs (e.g. the MagicBloom one) and am starting to suspect it's because Windows 7 DX11 is very different than Windows 10 DX11 (WDDM vs WDDM2 and all that fun stuff) and I just got lucky that it works on the former.
Cheers, crosire =)
Last Edit: 10 months 2 weeks ago by crosire.
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #8

Yeah, I'm on Windows 10.
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #9

I tried to reproduce this problem by installed Windows 7 on the same PC as when recording.
The administrator has disabled public write access.

About the blend of effect 10 months 2 weeks ago #10

Look at that. Will try and organize me a Win10 system for reproducing.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Wicked Sick

About the blend of effect 10 months 2 weeks ago #11

Got me a Win10 system and well ... this was super easy to fix: github.com/crosire/reshade/commit/af860f...66af612b9b88a738deb5. I just never saw that because that code path is explicitly disabled on Windows 7: github.com/crosire/reshade/blob/af860f3b...ntime_d3d11.cpp#L196. Don't even know why anymore, but there must be a good reason ...
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Daodan, seri14

About the blend of effect 10 months 2 weeks ago #12

I'm verified.

Would you reproduce and fix for MagicBloom's problem on Windows 10?

EDIT:
found commit v0.18.5
Last Edit: 10 months 2 weeks ago by seri14.
The administrator has disabled public write access.