Welcome, Guest.
Username: Password: Remember me

TOPIC: 3.3

3.3 3 months 1 day ago #1

Changelog

3.3.0:
  • You can now control the in-game UI with just your keyboard (this is useful in games where mouse input doesn't work properly)
    Use the ARROW keys to select a widget, SPACE to enter it, ESCAPE to leave it and ALT to switch to/from the menu bar.
  • Added "SaveWindowState" option. When set, ReShade will save UI widget positions/sizes and restore them on startup.
    [GENERAL]
    SaveWindowState=1
  • Fixed support for relative paths
  • Fixed performance mode hint popup not appearing and blocking all other popups from staying visible
  • Fixed crash if D3D11 device context was used before swapchain creation
  • Fixed invalid memory being read when "ui_items" list was not terminated with a '\0' character
  • Fixed it being impossible to remove a technique toggle key after it was set once

3.3.1:
  • Fixed "Block all input" option blocking input even if menu is not visible
  • Fixed timers showing wrong values after toggling technique status

3.3.2:
  • The setup tool now pre-selects only those effects that were previously installed, if updating an existing installation
  • Added log tab to the GUI (thanks to contribution by el3ment)
  • Added DX9 tab and option to disable buffer replacement with INTZ texture
    This option fixes shadow artifacts in Skyrim for example, but at the cost of no depth buffer access.
  • Added DX11 tab and moved buffer detection settings and debug window there
  • Fixed crash on exit in some OpenGL applications (e.g. X-Plane)
  • Fixed tutorial getting messed up if performance mode is active
  • Reduced font scale minimum and fixed FPS/clock text alignment with non-standard font scale
Cheers, crosire =)
Last Edit: 2 months 4 weeks ago by crosire.
The topic has been locked.
The following user(s) said Thank You: Wicked Sick, MrBeer, brussell, acknowledge, Echo, WalterDasTrevas, Ryukou36, Fu-Bama, Sunesha, Viper_Joe and this user have 11 others thankyou

3.3 3 months 1 day ago #2

I don't know if this version introduced it, but I think there is a bug in the calculation of post-processing times:

1. Enable a shader and bind a hotkey to it
2. Go into the Statistics tab, let's say the shader takes 1 ms to process
3. Press the hotkey a couple of times
4. Now the displayed post-processing time is not at 1 ms but rather 1, 2, 3, 4 ms... (depending on how often the hotkey was pressed)

So basically the displayed post-processing time gets offset by the value it had right before disabling, or something like that.
The topic has been locked.
The following user(s) said Thank You: DreamerN44

3.3 3 months 1 day ago #3

Thank you for update crosfire.
Wanted to ask about fixed issue > Fixed crash if D3D11 device context was used before swapchain creation
What game this would fix?
GIGABYTE B360M DS3H v1.0 | Intel i5 8400 + Corsair Cooling HYDRO Series H60 / 800 rpm on FAN
16GB (2x8) DDR4 Samsung 2400@2666Mhz 15-15-15-28 CR 1T (M378A1K43CB2-CRC) | Corsair RM650x 650W
EVGA GeForce GTX 1080 SC Gaming ACX 3.0 + 23" LCD Samsung S23C650
The topic has been locked.

3.3 3 months 1 day ago #4

Hello,
Windows Defender from Windows 10 detected this release as malware.

imgur.com/a/Q6RS73o
The topic has been locked.

3.3 3 months 1 day ago #5

  • Wicked Sick
  • Wicked Sick's Avatar
  • Offline
  • Die young or suffer (Forgive my poor English)
Thanks for the update, Crosire. I have the impression that this version glitches the Steam Overlay.
Finding relief somewhere between a tree's branch and its shade.
The topic has been locked.

3.3 3 months 1 day ago #6

Well... Mine Windows Defender haven't said it is a malware.
Also, ESET Internet Security 11.1.54.0 and Avast said it is not a malware.
Maybe it is just your problem...?
The topic has been locked.

3.3 3 months 19 hours ago #7

Thank you Crosire!!!!

And brilliant on the relative dirs and toggle key bug!
The topic has been locked.

3.3 3 months 18 hours ago #8

Got some problems/issues with the keyboard input :p

In DXHR (DC) if you select "block input/all input" you have NO input in-game :p (reshade menu CLOSED!)
And maybe in a lot of games.
Last Edit: 3 months 18 hours ago by lowenz.
The topic has been locked.

3.3 3 months 18 hours ago #9

Styx (1) is another example.
I think there's a LOT of games with the same issue (with old ReShade presets).
The topic has been locked.

3.3 3 months 16 hours ago #10

Daodan wrote:
I don't know if this version introduced it, but I think there is a bug in the calculation of post-processing times:
.

no it was there before, just reload the shaders and it gets fine again.

keyboard inpunt bugged for me too. Edit: looks like it's bugged only with performance mode on.
Last Edit: 3 months 13 hours ago by alex.
The topic has been locked.

3.3 3 months 16 hours ago #11

alex wrote:
Edit: looks like it's bugged only with performance mode on.
Swapping performance and configuration mode does nothing for me.
Can you double check? What game are you testing with?
Last Edit: 3 months 16 hours ago by lowenz.
The topic has been locked.

3.3 3 months 13 hours ago #12

In Fallout 4, I am unable to use any keys other than perhaps the arrow keys and the return key. I used those incidentally when I selected the saved game to play. It is more difficult to test in the game because I have no hotkeys in the game set as arrows or return. But none of my regular keys work, not even escape, so I must alt-tab (I believe that works) out of the game and kill it with task manager. I think I was supposed to be in configuration mode. I had just completed the tutorial, though I've used a previous version.
Last Edit: 3 months 13 hours ago by Convy.
The topic has been locked.

3.3 3 months 13 hours ago #13

lowenz wrote:
alex wrote:
Edit: looks like it's bugged only with performance mode on.
Swapping performance and configuration mode does nothing for me.
Can you double check? What game are you testing with?

yeah i didn't have time to check but now i'm playing again and it doesn't work on configuration mode either.
Convy wrote:
In Fallout 4, I am unable to use any keys other than perhaps the arrow keys and the return key. I used those incidentally when I selected the saved game to play. It is more difficult to test in the game because I have no hotkeys in the game set as arrows or return. But none of my regular keys work, not even escape, so I must alt-tab (I believe that works) out of the game and kill it with task manager. I think I was supposed to be in configuration mode. I had just completed the tutorial, though I've used a previous version.

set it to allow input when there is the overlay.
Last Edit: 3 months 12 hours ago by alex.
The topic has been locked.
The following user(s) said Thank You: Convy

3.3 3 months 4 hours ago #14

3.3.1 hotfix is out (and working) ;)
The topic has been locked.

3.3 2 months 4 weeks ago #15

3.3.0 installed normally, but 3.3.1 install file was detected as virus/malware, and blocked by windows defender.
The topic has been locked.

3.3 2 months 4 weeks ago #16

Alves wrote:
3.3.0 installed normally, but 3.3.1 install file was detected as virus/malware, and blocked by windows defender.

For me too, and VirusTotal returned what seems a false positive:
www.virustotal.com/#/file/a99322b70e60af...4137a9c5f3db237501b1

Could someone from the Reshade team open a verification request at Palo Alto site so they can remove the False Positive from their database?
live.paloaltonetworks.com/t5/VirusTotal/...rusTotal_Discussions
The topic has been locked.

3.3 2 months 4 weeks ago #17

is the first time i see a message from the GUI that a new version is available is it a new feature?

anyway, i would really like to disable this feature (for now i blocked the dll with a firewall rule), i prefer the reshade dll to not have access/open ports without me knowing.
The topic has been locked.

3.3 2 months 4 weeks ago #18

I really like this update. Thank You!
The topic has been locked.

3.3 2 months 4 weeks ago #19

im not sure fps counter works, I had like 5000 fps in cutscenes in mass effect andromeda and like 700 fps in rome 2 total war in battle.
My graphics card is a gtx 980, cpu i7 5820K
The topic has been locked.

3.3 2 months 4 weeks ago #20

Thanx a ton for this update.
The topic has been locked.