how to have mcfx dof disabled but can toggle on?

More
4 years 4 months ago #1 by maximumstats
(using reshade framework)
as it is, every time i alt-tab out and back i have to turn DoF off to see my UI properly and that's pretty annoying when I'm trying to look at lists of ingredient locations for crafting or somesuch. i'd like to have the DoF disabled by default, but then when I hit the toggle key, have it turn on. is that possible?

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #2 by crosire
Find the technique definition in McFX\DOF.h and set the "enabled" annotation to "false". That way it starts disabled.
technique DepthOfField_Tech < enabled = false; ... >
{
...
}
The following user(s) said Thank You: maximumstats

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #3 by maximumstats
Replied by maximumstats on topic how to have mcfx dof disabled but can toggle on?
thank you for your quick response! it works exactly as i wanted. :)

since its slightly different, i thought id post how my line now looks for searchability's sake:
technique DoF_Tech <bool enabled = false; int toggle = DoF_ToggleKey; >

Please Log in or Create an account to join the conversation.