Welcome, Guest.
Username: Password: Remember me

TOPIC: Need help regarding Cinematic DoF blur edges

Need help regarding Cinematic DoF blur edges 2 weeks 6 days ago #1

Hey,
I'm pretty new to ReShade, in Rise of the Tomb Raider I'm having an issue where I can't get a strong blur without getting the edges of the subject I want in focus blurred too. Could anyone help me ?

This is what I'm getting:



This is what I'd love to get:


(shot by Frans)

Also I'm using Frans' updated Cinematic DoF fx

Thank you
Anoh
The administrator has disabled public write access.

Need help regarding Cinematic DoF blur edges 2 weeks 6 days ago #2

In order to help you properly it would be good if you would post all of the CinematicDOF settings (and not just a small bit from the screenshot).
Based on the screenshot you would like to have Lara in-focus and the background out-of-focus, right?
Now - if that is true, and from what I can see - your far/near plane blur values are backwards and all the blur comes from the post blur smoothing.

Try that (at least that's how I go about setting up the DOF):
  1. Set the focal point
  2. Set these values:
    • Far plane max blur: 1.0
    • Near plane max blur: 0.0
    • Overall blur qual.: 5.0
    • Post-blur smoothing: 0.0
  3. Use the aperture and focal length to the get the DOF roughly to your liking
  4. Tweak the values from point 2

[Edit]
For a strong background blur you basically need a low aperture value an a high focal length.
Last Edit: 2 weeks 3 days ago by Daodan.
The administrator has disabled public write access.

Need help regarding Cinematic DoF blur edges 2 weeks 6 days ago #3

Thanks for replying, will post full settings tomorrow (can't right now).

I am aware that the near/far blur are inverted, I'm not sure why though when I increase the near blur it's the background that's affected. When I use the manual focal length I have to put it at 0.01 for it to be in focus on Lara. I've been messing around with the DOF settings and somethings doesn't feel right it doesn't make sense.

I'm using Hattiwatt's Cinematic Tools for the free cam by the way.
The administrator has disabled public write access.

Need help regarding Cinematic DoF blur edges 2 weeks 6 days ago #4

Anofelah wrote:
When I use the manual focal length I have to put it at 0.01...

I'm pretty sure you meant 'Manual-focus plane' ;-)
Generally I would suggest to use the auto-focus.
Easier to set up, I think.

[Edit]
Two images for reference:



Last Edit: 2 weeks 3 days ago by Daodan.
The administrator has disabled public write access.
The following user(s) said Thank You: Anofelah

Need help regarding Cinematic DoF blur edges 2 weeks 4 days ago #5

Anofelah wrote:
Thanks for replying, will post full settings tomorrow (can't right now).

I am aware that the near/far blur are inverted, I'm not sure why though when I increase the near blur it's the background that's affected. When I use the manual focal length I have to put it at 0.01 for it to be in focus on Lara. I've been messing around with the DOF settings and somethings doesn't feel right it doesn't make sense.
Make sure you have RESHADE_DEPTH_INPUT_IS_REVERSED set to 1 in the reshade settings (second tab). Then click 'reload' on the first tab to make it take effect. Use 'DisplayDepth' shader to make sure near camera is black and far away is white.

The shader just sees depth values, so if depth values far away are smaller than the focus plane's depth it thinks that's near the camera.

Make sure you also have proper lights in the background for nice highlight bokehs. The screenshot you linked to is from shadow of the tombraider in a scene where the background was dark but had these lights hanging on wires, which translated nicely to these bokehs. the scene you chose for testing doesn't have this however, so you likely end up with a white blob. Rise has some of these scenes however too:
www.flickr.com/photos/52066611@N00/44451...m-72157674389099842/
(done with an older version of the shader, the current one has better highlights)
The administrator has disabled public write access.
The following user(s) said Thank You: Anofelah

Need help regarding Cinematic DoF blur edges 2 weeks 4 days ago #6

Thanks for the reply, checked RESHADE_DEPTH_INPUT_IS_REVERSED and it's set to 1;

Checked DisplayDepth and all seems good:




But still after following what you and Daodan recommended the far blur doesn't seem to take effect when I increase it to 1 or more, despite any aperture and focal length I set:






Could it be because I'm using Matti's tools that it messes with the DoF?
The administrator has disabled public write access.

Need help regarding Cinematic DoF blur edges 2 weeks 4 days ago #7

Enable the display depth shader and DISable the dof, as display depth is above cinematic dof and thus is executed first.

It's weird indeed that it doesn't work, as I had no problems enabling it in Rise (in fact I used that to write the initial shader beta), although its depth buffer is rather shallow at times.

Your bottom shot has a large blue area which is odd. In-focus is a small line, not a big area, so something's definitely off.
The administrator has disabled public write access.
The following user(s) said Thank You: Anofelah

Need help regarding Cinematic DoF blur edges 2 weeks 4 days ago #8

I get a black screen when DisplayDepth is on, only way to see the black and white sections it to be changing the autofocus point.



Matti did update the tools very recently, maybe it has to do with the update they got.
The administrator has disabled public write access.

Need help regarding Cinematic DoF blur edges 2 weeks 3 days ago #9

One thing that could mess with the depth buffer is that if you're online.
I just tried it and it doesn't seem to matter but just to be sure: go offline, if you're not already.

Otherwise I'm at a pass here.

The only thing that comes to mind is to check your depth input setup:

Set these values in the preprocessor settings, these are the ones that I use:
RESHADE_DEPTH_LINEARIZATION_FAR_PLANE=1000.0
RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN=0
RESHADE_DEPTH_INPUT_IS_REVERSED=0
RESHADE_DEPTH_INPUT_IS_LOGARITHMIC=0
Now enable ONLY DisplayDepth, nothing else (or let it be the last shader that is executed). You should see near objects in black and far away objects in white.

I see that you also have MXAO in your shader list. That is also a good way to check the depth buffer with it's normal vector debug output. Take a look at this thread.

Oh, and I just tried the updated ROTTR Cinematic Tools and haven't encountered an issue.
Last Edit: 2 weeks 3 days ago by Daodan.
The administrator has disabled public write access.
The following user(s) said Thank You: Anofelah

Need help regarding Cinematic DoF blur edges 2 weeks 3 days ago #10

This is what fixed it:

RESHADE_DEPTH_INPUT_IS_REVERSED=0


Thank you so much to you and Frans for taking the time to help me resolve this! :)
The administrator has disabled public write access.

Need help regarding Cinematic DoF blur edges 2 weeks 3 days ago #11

Anofelah wrote:
This is what fixed it:

RESHADE_DEPTH_INPUT_IS_REVERSED=0
Thank you so much to you and Frans for taking the time to help me resolve this! :)
Yeah sorry about that! This morning I realized that it must have a non-reversed buffer. Luckily Daodan had this mentioned already :)
The administrator has disabled public write access.
The following user(s) said Thank You: Anofelah