Welcome, Guest.
Username: Password: Remember me

TOPIC: Lightroom Clarity

Lightroom Clarity 1 year 5 months ago #1

Hey everybody,

Would it be somehow possible to add an effect to reshade that acts like the "Clarity" filter on Adobe Lightroom? I tried it with saturation curves but i just couldnt get it to look anywhere near that. I don't know how to explain the Clarity filter and what it does, but somebody on the Internet said this : "I came to learn that the Clarity slider is mainly affecting the mid-tones. And it is affecting them by adding contrast, usually without much added noise."

Would be awesome if somebody could figure out something like it.
The administrator has disabled public write access.

Lightroom Clarity 1 year 5 months ago #2

  • Ioxa
  • Ioxa's Avatar
  • Offline
  • Posts: 267
  • Thank you received: 245
The mid-tone contrast enhancement in my high pass sharpening / contrast enhancement shader is based off this technique for recreating clarity. I don't have Photoshop so I can't make any direct comparisons, but based on pictures I've looked at I think it's pretty close. Try it out and let me know what you think.
Last Edit: 1 year 5 months ago by Ioxa.
The administrator has disabled public write access.

Lightroom Clarity 1 year 5 months ago #3

Thanks :) I've tried to add it to my current setup but it doesn't seem to work. I'm using MasterEffect ReBorn 1.0.340 so it's quite an older version. I've tried it on the game rFactor but it's refusing to work. :(
Maybe i did something wrong though, i'm quite the noob in that area.
I pasted the "HighPass_settings.cfg" lines to my "sweet.fx" (running reshade through gemfx) and it compiled on startup but there were no changes, so i added the "Sharp.h" stuff to my "sweet.fx" aswell, and that's where the errors started to pop up.
Did i f*ck up or is it because of my setup?
The administrator has disabled public write access.

Lightroom Clarity 1 year 5 months ago #4

  • Ioxa
  • Ioxa's Avatar
  • Offline
  • Posts: 267
  • Thank you received: 245
rFPhantom wrote:
Thanks :) I've tried to add it to my current setup but it doesn't seem to work. I'm using MasterEffect ReBorn 1.0.340 so it's quite an older version. I've tried it on the game rFactor but it's refusing to work. :(
Maybe i did something wrong though, i'm quite the noob in that area.
I pasted the "HighPass_settings.cfg" lines to my "sweet.fx" (running reshade through gemfx) and it compiled on startup but there were no changes, so i added the "Sharp.h" stuff to my "sweet.fx" aswell, and that's where the errors started to pop up.
Did i f*ck up or is it because of my setup?
You say you're using MasterEffect but you pasted the settings in Sweet.fx? Another potential problem is the HighPass_settings.cfg file is in the download for the ReShade + Framework version of the shader, so if you are using MasterEffect or SweetFX that won't work, there is a version that is meant to be used with SweetFX or MasterEffect, download that one. And you shouldn't need to cut and paste anything from the files, for the most part you just drop it into the game folder, read the Readme file that comes with the download.

And if you are somehow running MasterEffect, SweetFX, and GemFX, you should look into using ReShade + Framework which is a combination of the three along with some other custom shaders.
The administrator has disabled public write access.

Lightroom Clarity 1 year 4 months ago #5

I pasted it into the sweet.fx because i'm loading up reshade via gemFX and i renamed the reshade .dll and .fx to sweet. :) I tried adding this shader via "#include "ReShade.fx"" in my sweet.fx and it seems to load up the shader, but i get a compiling error. :/
The administrator has disabled public write access.

Lightroom Clarity 1 year 4 months ago #6

  • Ioxa
  • Ioxa's Avatar
  • Offline
  • Posts: 267
  • Thank you received: 245
Ok, I think I understand what you're doing. You're using MasterEffect, but you have renamed the ReShade.fx file to Sweet.fx. If that is what you've done then try renaming the ReShade.fx file that comes with the high pass shader to Sweet.fx and rename the MasterEffect file to ReShadeME.fx. Then open HighPass_settings.h (which is in the SweetFX folder) and set Compatibility to 2.

If that doesn't work, set Compatibility back to 0 and use the option to chain additional .fx files, it's just below the Compatibility setting. Set USE_EFFECT1 to 1 and define FX_FILE1 as "ReShadeME.fx".

Just curious, is there a reason you prefer to use MasterEffect and GemFX this way instead of just using the Framework?
The administrator has disabled public write access.

Lightroom Clarity 1 year 4 months ago #7

I tried both versions you described and they then gave compiling errors for the ReShadeMe.fx file which was my sweet.fx before. I don't know why it only loads one of the .fx files without problems, and i can't really figure it out. Could it be because i'm using an older version of MasterEffect? I'm always updating my reshade .dll file but the .fx file stays the same because, if im not mistaken, the new MasterEffect barely has any of the effects that i'm using anymore.

And i'm using it with this setup because i was first using GemFX only, before i knew Reshade existed, and then later on added Reshade to it because i liked how it looked with GemFX but i really wanted a good bokeh DoF which i was able to get then. Has been working fine so far (on the game rFactor) but after i edited a screenshot in Lightroom and added the Clarity filter on it i really want my game to look that way, haha.
The administrator has disabled public write access.

Lightroom Clarity 1 year 4 months ago #8

  • Ioxa
  • Ioxa's Avatar
  • Offline
  • Posts: 267
  • Thank you received: 245
What is the error that you're getting? Maybe something is being redefined somewhere.

I never use DoF so I don't know if there are any differences between the Framework DoF and what you're using now, but if you're happy with what you're using I guess theres no reason to start over and try to get the same look again.
The administrator has disabled public write access.

Lightroom Clarity 1 year 4 months ago #9

When i load up my .fx file through your .fx file i get the "redefining defined.." error for all effects of the MasterEffect, and vice versa. I might try the Framework on a new install of the Game and try it there. :)
The administrator has disabled public write access.

Lightroom Clarity 1 year 4 months ago #10

  • Ioxa
  • Ioxa's Avatar
  • Offline
  • Posts: 267
  • Thank you received: 245
Make sure you deleted all the code you pasted into the file. Also make sure you aren't still trying to chain in ReShade.fx from the MasterEffect fx file.
The administrator has disabled public write access.