Welcome, Guest.
Username: Password: Remember me

TOPIC: Screenshot-Key does not work anymore

Screenshot-Key does not work anymore 1 year 2 months ago #1

Hey guys,
i have got a problem with ReShade + Mastereffects. Ive got the newest Version of both of them and an shader preset. Some times ago i did not have any problems when taking screenshots with my "print"-button, the screenshot had been saved in the directory of the Game (GW2 in this case) and in the documents folder without the shaders. And now it just saves the screenshots in the documents folder without the shader, hahlp pls :c
The administrator has disabled public write access.

Screenshot-Key does not work anymore 1 year 2 months ago #2

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 609
  • Thank you received: 716
That must be ReShade issue itself, MasterEffect doesn't change screenshot path (is that even possible?). Maybe Crosire can enlighten us.
Last Edit: 1 year 2 months ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: Silver

Screenshot-Key does not work anymore 1 year 2 months ago #3

it's definitely possible, Crosire posted how, this should be the syntax unless changed recently:

#pragma reshade screenshot_location "C:/......./MyScreenshots" (sub in whatever folder you want it to be in the quotes)

You just need to make sure this line is in an .fx being used by reshade (most likely reshade.fx should work)
Last Edit: 1 year 2 months ago by sajittarius.
The administrator has disabled public write access.

Screenshot-Key does not work anymore 1 year 2 months ago #4

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 609
  • Thank you received: 716
Well, I'm not so up to date with those pragmas as I rarely update the dll I use so I still use 0.18 or something like that. As a result, MasterEffect does not use this pragma. Maybe the default location changed when Crosire implemented the change directory feature.
The administrator has disabled public write access.

Screenshot-Key does not work anymore 1 year 2 months ago #5

I added #pragma reshade screenshot_location "C:\Program Files (x86)\Guild Wars 2" into my ReShade.fx file but it still does not work ;(
@Crosire help pls ._.
The administrator has disabled public write access.

Screenshot-Key does not work anymore 1 year 2 months ago #6

Sorry for Doublepost but problem solved, i took the folder from Program Files [x86] into C:\ and now it works... seems like the shader did not had any permissons to save the pictures into that directory ... weird :s
The administrator has disabled public write access.

Screenshot-Key does not work anymore 1 year 2 months ago #7

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
You don't have permission to write to the program files folder, unless you give them to you (folder properties => Security => Edit) or you run the application as administrator.
Cheers, crosire =)
The administrator has disabled public write access.