Welcome, Guest.
Username: Password: Remember me

TOPIC: Depth Buffer (MasterEffect) always black screen.

Depth Buffer (MasterEffect) always black screen. 1 year 2 months ago #1

I downloaded the latest MasterEffect. Everytime I enable the depth buffer the screen goes black. The Witcher 3 as well as Dying Light were tested. I made sure the right ReShade was installed (dxgi, 64bit etc.).
What am I doing wrong ?
The administrator has disabled public write access.

Depth Buffer (MasterEffect) always black screen. 1 year 2 months ago #2

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 610
  • Thank you received: 720
If you look up both games in this table here, you will see that both have a note "Game uses a logarithmic depth buffer.".
This means that the depth output those games deliver is not matching with majority of other games, probably because both have an insane view distance.
The hardware depth buffer is not linear but in order to use it for DOF we need to linearize it (so actual distance to an object is proportional with the depth value). As the output of those games is different than most others, the usual function I use to make the depth data linear outputs weird values that most of the time result in blackscreen.
When using the Framework, you can switch to an alternate linearizing function for such logarithmic depth buffers but MasterEffect doesn't have this function. As I don't continue work on ME anymore (only bugfixes and this hardly qualifies), you will have no other option than using the (way better) Framework.
Last Edit: 1 year 2 months ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: Radion