Welcome, Guest.
Username: Password: Remember me

TOPIC: Godrays - Threshold not working

Godrays - Threshold not working 1 year 1 month ago #1

  • Ederer
  • Ederer's Avatar
  • Offline
  • Posts: 9
  • Thank you received: 3
The GodrayThreshold for the GemFX Godrays doesn't work. It always uses a low threshold (if any) which makes the image super bright with godrays everywhere - not usable for playing.
This can be best seen when turning of the DEPTH-CHECK off...

I remember a working verion, but i think this was before the framework when the godrays were included in Mastereffects...
The administrator has disabled public write access.

Godrays - Threshold not working 1 year 1 month ago #2

  • Marty McFly
  • Marty McFly's Avatar
  • Offline
  • We've tried nothing and we're all out of ideas!
  • Posts: 609
  • Thank you received: 716
What value range are you using?
The administrator has disabled public write access.
The following user(s) said Thank You: Ederer

Godrays - Threshold not working 1 year 1 month ago #3

  • Ederer
  • Ederer's Avatar
  • Offline
  • Posts: 9
  • Thank you received: 3
you mean for the Threshold?
It doesn't have any effect. I can set it to 0.6 (minimum) and it looks the same as 1.0 (which shouldn't create any godrays at all).

Here are some screenshots ( i turned off the depth-check, all other settings are default! ).
The Threshold is 0.9 (default) and it looks horrible.... :unsure:

Original:


Godrays ON:


Mediator settings:
Last Edit: 1 year 1 month ago by Ederer.
The administrator has disabled public write access.

Godrays - Threshold not working 1 year 3 weeks ago #4

  • Ederer
  • Ederer's Avatar
  • Offline
  • Posts: 9
  • Thank you received: 3
it seems to me now that the problem could be more the turned off depth check... when turned off even in older masterfx versions it doesn't work properly anymore...
Anyway, for online games depth cannot be used, so can you please look into this? :)
The administrator has disabled public write access.

Godrays - Threshold not working 1 year 3 weeks ago #5

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
Are you sure this is the God Ray effect? Looks more like one of the lens effects. You might want to tweak or turn off those.
The administrator has disabled public write access.
The following user(s) said Thank You: Ederer

Godrays - Threshold not working 1 year 3 weeks ago #6

  • Ederer
  • Ederer's Avatar
  • Offline
  • Posts: 9
  • Thank you received: 3
I'm sure, it's a completely new default preset, and no other effects are enabled... -> easy to reproduce ;-)

On the Godrays i only changed the depth check to 0, as you can see in the last screenshot.

But i also noticed:
even though the "Bloom" effect is DISABLED in the Pipeline, it still has an effect when godrays are enabled. You can see this when you go to the Bloom-Settings and increase the "Amount".
Just mentioning, in case it helps...
Last Edit: 1 year 3 weeks ago by Ederer.
The administrator has disabled public write access.

Godrays - Threshold not working 1 year 3 weeks ago #7

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
The blur of the bloom shader is necessary for the God Rays (and other shader).

I identified the problem as in the following:

Open the Bloom.h file in /ReShade/GemFX folder.

Change the line
lens.xyz += sample2.rgb;

To
lens.xyz += sample2.xyz*sample2.w;

Enjoy god rays without depth buffer check ;)
Last Edit: 1 year 3 weeks ago by Ganossa.
The administrator has disabled public write access.