Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Fountain of Failure

Fountain of Failure 1 year 6 months ago #1

  • Golgotha
  • Golgotha's Avatar
  • Offline
  • Posts: 20
  • Thank you received: 8
Ok this is a major violation of neural circuitry actually posting on a forum to ask for help, but I am seriously about to lose my feces. I can just about always figure out whatever problem I'm having by searching relevant forums and harvest the fruits of other people's similar misfortunes; but after several hours of searching these and other forums, youtube and troubleshooting while ensnarled in a teeming morass of text editors so deep I contemplated Kickstarting Desktop Scuba, I find myself thoroughly pickled in the acidic juices of my own failure.....

...(This is why I don't post in forums; I can't seem to get down with the TLDR nature of the world and get to the damn point! Its a sickness.

I want love the mediator unconditionally and sing its praises so loudly I get shushed by Swiss Alpine shepherds and lectured about the relationship between acoustic phenomena and avalanches and it is wonderful until ... yes the bush is about to get beat, now that I've flattened a crop circle around said bush in a tantric buildup rendering the poor shrubbery of my damn point throbbing in near epilepsy of anticipation..

...TLDR until... I try to import a preset. I'm not even talking about crawling the lazy whatever or porting from previous versions. I'm talking about other's presets made with the same 1.1 framework version. I make sure the preset folder looks like the others in the preset directory and it seems like it should be simple..... the box on the left deals with the games .exe and then I could just switch the preset it is linked to using the dropdown menu of the box on the right. However whenever I add a folder to the preset folder that wasn't generated by my own fiddlings, this lovely little tool morphs into an orifice of Satan's lies.

All the shader suites disappear, leaving only Setup and Pipeline, yet no response is forthcoming when I click on them. Pressing update starts a charming conversation where mediator whispers such sweet nothings as "files could not be loaded. Input string has incorrect format" and my favorite, "9996 is not a valid entry. Please choose a value between the minimum and maximum value" ... A thorough search of every reshade file on my system is made and nary a 9996 to be found. Even after I delete it and put back everything the way it was, mediator remained in this crippled state. The first time luckily I had a system drive image only 12 hours old. Now I back up all the reshade folders before I mess with anything.

*Towel thrown. Anybody wiser than I have a solution? Sorry if I posted in the wrong place or have perpetrated any other violations; my nerves are a little shot at this point.
The administrator has disabled public write access.

Fountain of Failure 1 year 6 months ago #2

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
Well written :silly:
Usually I would guess its a problem with values in the file if thats what the mediator gives back as feedback but since you said the called out number does not exist in the config files, it might have to do with the encoding of the cfg text files.

Could you pass me those files? Though I might not be able to look into it right away.
Last Edit: 1 year 6 months ago by Ganossa.
The administrator has disabled public write access.
The following user(s) said Thank You: Golgotha

Fountain of Failure 1 year 6 months ago #3

  • Golgotha
  • Golgotha's Avatar
  • Offline
  • Posts: 20
  • Thank you received: 8
Thanks for offering to help. I had deleted the offending files but I thought, I created the problem about 10 times easily enough, I'll just do it once more" Only now I can't recreate the same problem. Now the rabbit hole is that it keeps overwriting the new preset with the preset already loaded. I've tried so many ways It would be a nightmare trying to recount them all.

Maybe if someone explained exactly what it is I am supposed to do. I've seen so many, many tutorials on how to create a single preset; how to select the exe..., update etc. That's never been a problem; that part is just beautiful.... alt tabbing out of a game, making a quick tweak and back again in 5 seconds... I just love it. I just want to download presets from those who use completely different shaders and be able to switch back and forth between presets.

I just want to whore my folders to all sorts of cfgs without having to manually chat each one up, one at a time. Please help me fulfill my dream.

PS It would be a great help if someone could untangle the spaghetti of logic that entangles the 3 boxes on the right and the multiple preset and profile folders in the main reshade directory and the one in the game directory. I've gotten by so far by finding a sequence of actions that work, but I have no idea why. However it seems by now I should have done it correctly by accident at least. I just can't seem to synthesize a full explanation from all of the partial explanations I've found. Many thanks in advance :)
The administrator has disabled public write access.

Fountain of Failure 1 year 6 months ago #4

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 838
I guess you did the tutorial already?

Profiles store app information
Presets store configurations

Profiles link to non or one preset.
Presets link to any number of profile.

A preset and profile are automatically linked when selected together.

A linked preset will always be loaded when the linked profile was selected.

Profiles can be added, deleted or updated.
Add installs binaries and a symlink to the mediator.
Delete removes those.
Update will overwrite the installed binaries.

Presets can be added, deleted or updated.
Add will create a new preset if non existent with the currently active configuration.
Delete will delete the selected preset.
Update will overwrite the currently selected preset with the currently running configuration.

Apply on the top right applies changes to the currently running configuration ( not to the preset ).
We are currently thinking about bringing presets and currently running configurations closer together.
The administrator has disabled public write access.
The following user(s) said Thank You: Golgotha

Fountain of Failure 1 year 2 months ago #5

  • Golgotha
  • Golgotha's Avatar
  • Offline
  • Posts: 20
  • Thank you received: 8
Sorry, I seem to have spaced out for a few months there! Anyway, I finally got it working after reinstalling and starting over a few times. I have no idea why, but after the 3rd or 4th time the weird errors stopped and never came back. Kind of a moot point now that we're at 2.0 and that process seems a lot more streamlined now, but I felt bad after realizing I left you hanging like that. Thanks again :)
The administrator has disabled public write access.