Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Depth in Dark Soulds 2 Scholar of the first Sin

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 3 weeks ago #1

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Hello, I'm trying to install a preset for Dark Souls 2 Scholar of the first sin (the dx11 version of DS2), everything works as it is supposed to work except the AO and DoF which just don't work. It seems the depth buffer is the culprit right ? I took a screenshot with split screen and depthbuffer out ON to show you :

But the depth buffer is supposed to be accessible as seen here, am I wrong ? : sfx.thelazy.net/games/screenshot/31870/
or here, another preset which I didn't manage to use either (except for effect like colorimetry sfx.thelazy.net/games/screenshot/22519/

I wonder what step I'm missing .. is it because I'm on W10 ?
The administrator has disabled public write access.

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 3 weeks ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
foudelou wrote:
But the depth buffer is supposed to be accessible as seen here, am I wrong ?
Disable any AA method the game provides.
Cheers, crosire =)
The administrator has disabled public write access.

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 3 weeks ago #3

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Thanks for the answer, I tried but without success .. I disabled every in game effect actually to be sure, motion blur, dof, ao .. but still no Z buffer :o

For info : w10 64 bits, GTX 970 , 2500k
Last Edit: 11 months 3 weeks ago by foudelou.
The administrator has disabled public write access.

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 2 weeks ago #4

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
I finally managed to make Z buffer work somehow with reshade by activating #define RFX_PseudoDepth in common.cfg ( #define RFX_LogDepth doesn't work) but it made appear a huge artifact in the middle of the screen :
The administrator has disabled public write access.

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 2 weeks ago #5

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
foudelou wrote:
I finally managed to make Z buffer work somehow with reshade by activating #define RFX_PseudoDepth in common.cfg ( #define RFX_LogDepth doesn't work) but it made appear a huge artifact in the middle of the screen
That option is exactly what it says. It loads a static pseudo depth buffer from a texture (ReShade\BasicFX\Textures\dMask.png). This is for testing and not what you want. If the depth buffer output is black, then there isn't any depth input to use, no option will change that.
Cheers, crosire =)
Last Edit: 11 months 2 weeks ago by crosire.
The administrator has disabled public write access.

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 2 weeks ago #6

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Thanks .. but how do you explain the presets I linked earlier are working then ? There clearly is AO and DOF activated on the screens :S
The administrator has disabled public write access.

Depth in Dark Soulds 2 Scholar of the first Sin 11 months 2 weeks ago #7

  • foudelou
  • foudelou's Avatar
  • Offline
  • Posts: 16
  • Thank you received: 1
Okay I finally managed to make Zbuffer work ! Or at least I understand what is the problem : it only works in 16/9 ratio... I launched the game in windowed 1600x900 and DoF was here, unfortunately my screen is a 16/10 and the game is vertically stretched when a 16/9 resolution is used
Now why it doesn't work in 16/10 and is it possible to make it work on it .. I have no idea but I guess I don't really have a choice then :pinch:

edit : problem solved : simply change the scaling in the nvidia control panel , thanks piltrafus !
Last Edit: 11 months 2 weeks ago by foudelou.
The administrator has disabled public write access.