Welcome, Guest.
Username: Password: Remember me

TOPIC: help with tone mapping + liftgamagain

help with tone mapping + liftgamagain 10 months 1 day ago #1

hey all hopeing this is the right place to get some help. iv been trying to customise a reshade preset for fallout 4 from the nexus to better suite me(Xtream Cinema normal). i realy like the colors used in the preset but its to dark in interiors so i want to try and customise it to fix the dark issue. i have next to no experince with editing reshade files but I have had a look in the cfg to turn on and of settings to see what could be the main culprit and in doing so. the main setting witch seems to make it so dark is tone mapping and lift gamagain in the sweetfx.cfg. turnign this off makes the image bright again but i loos the color that i really like. I had a mess around with it but i just cant seem to understand how it works and what setting i need to adjust just to correct the brightnes without effecting the change of the color tone .tryd gama gain but not sure what im doing.can someone maybe help me with this or instruct me on another setting i can either turn on or adjust to get what im aiming for. the current values are this. thanks

//>Lift Gamma Gain settings<\\
#define RGB_Lift float3(1.150,1.250,1.270) //[0.000:2.000]
#define RGB_Gamma float3(0.960,1.000,1.000)
#define RGB_Gain float3(0.920,0.920,0.920)

//>Tonemap settings<\\
#define Gamma 1.000
#define Exposure 0.000
#define Saturation -0.000
#define Bleach 0.000
#define Defog 0.180
#define FogColor float3(1.00,1.20,1.00)
The administrator has disabled public write access.

help with tone mapping + liftgamagain 10 months 1 day ago #2

  • Sekta
  • Sekta's Avatar
  • Offline
  • Posts: 20
  • Thank you received: 5
Can you link this preset? The only preset I could find was an ENB/ReShade one that did not use any colour modification shaders like you described because it used a LUT.

The easiest way to fix your problem would be to undo any changes you made, convert the preset to a LUT using Mediator. Open the LUT in Photoshop, and import the original LUT (in CustomFX folder) to a new layer and then change the blending mode to Luminosity. That way you have the preset with the original brightness and modified colours. Then you can just reduce the opacity of that layer until you find the perfect brightness you want.

I can do this for you if you link the preset you used.
Last Edit: 10 months 1 day ago by Sekta.
The administrator has disabled public write access.

help with tone mapping + liftgamagain 10 months 20 minutes ago #3

forgot to quote you sorry
Last Edit: 9 months 4 weeks ago by domjam.
The administrator has disabled public write access.

help with tone mapping + liftgamagain 9 months 4 weeks ago #4

Sekta wrote:
Can you link this preset? The only preset I could find was an ENB/ReShade one that did not use any colour modification shaders like you described because it used a LUT.

The easiest way to fix your problem would be to undo any changes you made, convert the preset to a LUT using Mediator. Open the LUT in Photoshop, and import the original LUT (in CustomFX folder) to a new layer and then change the blending mode to Luminosity. That way you have the preset with the original brightness and modified colours. Then you can just reduce the opacity of that layer until you find the perfect brightness you want.

I can do this for you if you link the preset you used.

hey thanks for the reply. i forgot to mention that the preset dose use enb aswell. but the enb is not really a problem since even with it of its still to dark.. here is the link for you to have a look. if you can be of further asistance that would be awsome www.nexusmods.com/fallout4/mods/347/?
The administrator has disabled public write access.

help with tone mapping + liftgamagain 9 months 4 weeks ago #5

  • Sekta
  • Sekta's Avatar
  • Offline
  • Posts: 20
  • Thank you received: 5
The preset already uses a LUT in addition to all of the other colour modifying shaders. I merged all of these shaders together into a LUT. The shadows are clipped really badly.

Blue shows clipped shadows.


The preset is this dark because it uses AmbientLight, Bloom, etc. When these come into effect, the image is a lot brighter. When these aren't present, then you get those severely clipped shadows. If you brighten the shadows so it's tolerable without these shaders, then it becomes too bright when these shaders come back into effect.

I brightened the shadows but since the preset relies on ENB, AmbientLight, Bloom, etc, I did not brighten them too much. Indoors may still be too dark for you. The light effects will also not be as strong since the extreme contrast is no longer there but that's the compromise you have to make.

Before
All shaders: i.picpar.com/JeHb.jpg
Colour alone: i.picpar.com/IeHb.jpg

After
All shaders: i.picpar.com/KeHb.jpg
Colour alone: i.picpar.com/LeHb.jpg

LUT


Save the LUT image and put in your ReShade CustomFX textures folder.
Disable Technicolor, DPX, LiftGammaGain, Tonemap, Vibrance, Curves, FilmicPass, ReinhardLinear, SphericalTonemap, HDR, HPD.
In TuningPalette, set the Color LUT texture to the name of the LUT and the AmountX to 1024 and AmountY to 32.
Last Edit: 9 months 4 weeks ago by Sekta.
The administrator has disabled public write access.

help with tone mapping + liftgamagain 9 months 3 weeks ago #6

Sekta wrote:
The preset already uses a LUT in addition to all of the other colour modifying shaders. I merged all of these shaders together into a LUT. The shadows are clipped really badly.

Blue shows clipped shadows.


The preset is this dark because it uses AmbientLight, Bloom, etc. When these come into effect, the image is a lot brighter. When these aren't present, then you get those severely clipped shadows. If you brighten the shadows so it's tolerable without these shaders, then it becomes too bright when these shaders come back into effect.

I brightened the shadows but since the preset relies on ENB, AmbientLight, Bloom, etc, I did not brighten them too much. Indoors may still be too dark for you. The light effects will also not be as strong since the extreme contrast is no longer there but that's the compromise you have to make.

Before
All shaders: i.picpar.com/JeHb.jpg
Colour alone: i.picpar.com/IeHb.jpg

After
All shaders: i.picpar.com/KeHb.jpg
Colour alone: i.picpar.com/LeHb.jpg

LUT


Save the LUT image and put in your ReShade CustomFX textures folder.
Disable Technicolor, DPX, LiftGammaGain, Tonemap, Vibrance, Curves, FilmicPass, ReinhardLinear, SphericalTonemap, HDR, HPD.
In TuningPalette, set the Color LUT texture to the name of the LUT and the AmountX to 1024 and AmountY to 32.

hey thanks for this..sorry for the delay in respons..it is better but still shadows are displaying totale black insted of showing bits of the detail when compert to vanila inside interieors...so is it just not possible with this kind of tonemapping then? thanks for your help
The administrator has disabled public write access.