Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] on / off toggle with MasterEffect

on / off toggle with MasterEffect 2 years 8 months ago #1

  • NattyDread
  • NattyDread's Avatar
  • Offline
  • Posts: 87
  • Thank you received: 90
On / off toggle key doesn't work while using the ReShade.fx (MasterEffect). Works fine without it.
The administrator has disabled public write access.

on / off toggle with MasterEffect 2 years 8 months ago #2

  • Nekrik
  • Nekrik's Avatar
  • Offline
  • Posts: 58
  • Thank you received: 29
On / off toggle key as well as depth buffer visualization with "Alt" key is currently works only with SweetFX 2.0+Reshade Combo.
The administrator has disabled public write access.
The following user(s) said Thank You: NattyDread

on / off toggle with MasterEffect 2 years 8 months ago #3

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2781
  • Thank you received: 1582
Those keys are set in the shader, but MasterEffect does not have one set.

You can set one yourself though: Find the technique declaration in the shader and add the following right after "bool enabled = true;":
int toggle = 0x91;
If you want a different key, use one of the keycodes from here.
Cheers, crosire =)
Last Edit: 2 years 8 months ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: NattyDread, Midhras

on / off toggle with MasterEffect 2 years 8 months ago #4

  • NattyDread
  • NattyDread's Avatar
  • Offline
  • Posts: 87
  • Thank you received: 90
Works great, thanks.
Why doesn't MartyMcfly have a thread here already? I have "a couple" of questions for him. :P ...and I don't have a fb account.
The administrator has disabled public write access.

on / off toggle with MasterEffect 2 years 6 months ago #5

  • piterrrxd
  • piterrrxd's Avatar
  • Offline
  • Posts: 47
  • Thank you received: 51
I add this line to ReShade.fx and doesn't work.
͡° ͜ʖ ͡° Unreal Witcher 3 sfx.thelazy.net/games/preset/3911/
The administrator has disabled public write access.

on / off toggle with MasterEffect 2 years 6 months ago #6

  • brussell
  • brussell's Avatar
  • Offline
  • Posts: 167
  • Thank you received: 131
piterrrxd wrote:
I add this line to ReShade.fx and doesn't work.

It should look like this (with SCROLL LOCK key):
technique MasterEffect < bool enabled = 1; toggle = 0x91; >
The administrator has disabled public write access.

on / off toggle with MasterEffect 2 years 6 months ago #7

  • piterrrxd
  • piterrrxd's Avatar
  • Offline
  • Posts: 47
  • Thank you received: 51
I checked now in Dead Space and work fine. The problem is with Darksiders, maybe because x360ce is in "Hook mode". There is no virtual-key codes for the gamepad buttons?
͡° ͜ʖ ͡° Unreal Witcher 3 sfx.thelazy.net/games/preset/3911/
The administrator has disabled public write access.