Grand Theft Auto IV DOF problem [ReShade 2.0.3f1]

  • Posts: 4
3 years 9 months ago - 3 years 9 months ago #1 by Kubo
Hi, i have a problem with autofocus, seems make dof stop working.
I'm working on my graphics mod for a few months, and before 2.0 came out i was using 1.1.
In v1.1 dof and autofocus work great. I'm reading some topics about dof problems but no one solve mine.

So, dof works, but when i set autofocus=1 seems not working anymore, some examples:
#1
Warning: Spoiler! [ Click to expand ]


#2
Warning: Spoiler! [ Click to expand ]


#3
Warning: Spoiler! [ Click to expand ]


This is my dof setting (it's a "just for test if it works" setting):
Warning: Spoiler! [ Click to expand ]


And this my global.cfg setting:
Warning: Spoiler! [ Click to expand ]


Sorry for my bad english and thanks in advance for replies:)
I take this opportunity to congratulate crosire, ganossa and others for their work.

Please Log in or Create an account to join the conversation.

  • Posts: 1225
3 years 9 months ago #2 by Marty McFly

#define DOF_FARBLURCURVE 0.05 //[0.05:5.00] //-Curve of blur behind focal plane. Higher means less blur.
#define DOF_MANUALFOCUSDEPTH 0.02 //[0.00:1.00] //-Depth of focal plane when autofocus is off. 0.0 means camera, 1.0 means infinite distance.


Issue right there. Such a low far blur curve makes blur build up almost instantly to maximum behind focal plane. And the second value ensures that the focus depth is almost at the camera itself so you have a sharp area until like 20cm from the camera away and then blur kicks in with almost instantly full power.
The following user(s) said Thank You: Kubo

Please Log in or Create an account to join the conversation.

  • Posts: 4
3 years 9 months ago - 3 years 9 months ago #3 by Kubo
Thanks for reply. My problem is when autofocus is on, why the image is not blurred anymore? Or at least blurred behind the focus?
Also putting "RESHADE_DEPTH_INPUT_IS_REVERSED" and "RESHADE_DEPTH_INPUT_IS_LOGARITHMIC" to 1 autofocus seems not working:/
In v1.1 it worked perfectly.

Please Log in or Create an account to join the conversation.

  • Posts: 1225
3 years 9 months ago #4 by Marty McFly
Changes (not by me) in linearizing depth algorithm. Enable depth buffer output and try to tweak the depth buffer values until you have a smooth gradient from black (close) to white (far).
The following user(s) said Thank You: Kubo

Please Log in or Create an account to join the conversation.

  • Posts: 4
3 years 9 months ago #5 by Kubo
In DisplayDepth there are no values, with "depth buffer values" you mean "RESHADE_DEPTH_LINEARIZATION_FAR_PLANE" in global.cfg?
For now my screen is fully black with DisplayDepth enabled.

Please Log in or Create an account to join the conversation.

  • Posts: 24
3 years 9 months ago #6 by kurtferro
//>Depth Settings<\\
#define RESHADE_DEPTH_LINEARIZATION 1 //[0:1] //-Set this to zero for games without depth buffer access or if you do not use any depth dependent effects.
#define RESHADE_DEPTH_LINEARIZATION_FAR_PLANE 1000.0 //[0.0:100000.0] //-The far clipping plane distance.
#define RESHADE_DEPTH_INPUT_IS_UPSIDE_DOWN 0 //[0:1] //-Set this to one for games where the depth buffer is upside down.
#define RESHADE_DEPTH_INPUT_IS_REVERSED 0 //[0:1] //-Set this to one for games using a reversed depth buffer.
#define RESHADE_DEPTH_INPUT_IS_LOGARITHMIC 0 //[0:1] //-Set this to one for games using a logarithmic depth buffer.



in Global.cfg test all option
The following user(s) said Thank You: Kubo

Please Log in or Create an account to join the conversation.

  • Posts: 4
3 years 9 months ago #7 by Kubo
Ty, i'll try

Please Log in or Create an account to join the conversation.

  • Posts: 52
3 years 5 months ago #8 by SiriusHours
you still having issues?

Please Log in or Create an account to join the conversation.